0

Hi everyone out there,
I have a dual boot machine where I run wins and ubuntu 10.04.I usually connect to a windows network for both environments and things were working fine then all of sudden ubuntu stopped connecting to the internet.I tried to check my network settings and everything seems okey with the connection speed and exchanged bits indicated.Can anyone out there show me the way please coz I wanna have fun with linux online!

5
Contributors
9
Replies
10
Views
6 Years
Discussion Span
Last Post by HereInOz
0

hi there today,Rubberman thnx for the reply.the command sudo ifconfig gave me connection details like the transmitted andreceived packets, the ip address,there are 0 bytes dropped,0 errors, 0 overruns amongst the others.my browser and other programs that require internet connectivity can't however do so depite these details.any clues? thanks n long live daniweb!!!!

0

Yes, well I asked for the output (rather than a synopsis) in order to get some better idea of what is going on. Please post. Thanks.

0

Hi,
Well,thanks for your response! Here is the typed output of the command you provided. The only thing I have omitted is my IP address,otherwise all is just a replication of the output. Look forward to your solution. Cheers!

Link encap:Ethernet Hw addr..........
UP Broadcast running multicast:mtu:1500 Metric 1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
Collisions:0 txqueuelen:1000
RX bytes:6597(6.5kb) TX bytes:5486(5.4kb)
Interrupt:32 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
inet6 addr: ::1/128 scope :host
Up loopback Running MTU:16436 Metric 1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 frame:0
Collisions:0 txqueuelen:0
RX bytes:720(720.0B) TX bytes:720(720.0B)

0

that first connection shoumd probably be your LAN connection, but you didnt list it as eth0 like one would expect... and it doesnt have an IP address. check your network manager, make sure it's set up appropriately... that is, for dhcp/manual... also dns servers and appropriate subnet mask. you mentioned that it connects to a "windows network"... is this a work computer? if not, is there something about your network that makes it a windows network?

please do a sudo ifconfig -a that will show the status of any connections that are down. possible that eth0 (or the equivalent for your machine) is simply down, and a sudo ifconfig eth0 up (for example) would be a (likely too-easy) fix. a second possibility is that a reboot might resolve it... cold restart if a warm one fails.

i dont want to get too deep while we're still guessing here, so that's it for now.

0

Hi there again,
Thank you both for your efforts.Tje210,as you had guessed, the first details are for the eth0, it's just that I forgot to mention it while typing but do forgive me for that!I did try out your options and it all came to the same.I just realised something with mozilla firefox on both linux and windows.While IE responds well on my network which runs at 100 mbps,firefox has refused to connect at all.I had just thought may be it may be a problem with firefox itself but on realising that the other programs trying to access the internet in linux failing too,i just got more confused.What must be happening for I used to connect on the same network before without problems and I haven't made any cahnges to my system.

0

hi guys,
Thanks to you all who tried and surely all your efforts were massive. I did transfer my computer to another location and guess what! I GOT LINUX WORKING, but what is still beating my mind is the reason why it refused on the previous network. This same network has macs working on it and they fine. Has anyone ou there come across this same problem? Gurus, what have you to asy about this?

0

I have had experience with some modem/routers, particularly D-Link, not properly providing DHCP to an Ubuntu machine. Having said that, it was back in the Dapper Drake days, and since then I have avoided D-Link devices like the plague.

It is possible that the issues are still there with the later Ubuntu versions. Was the offending modem/router a D-Link by any chance?

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.