0

Dani,

When I run the rpm -Uvh command it tells me that the rpms are already installed. If I run mplayer I have to supply all of the strings to play a file. I installed the mplayer gui version, is it not really a gui player. Thanks for all of the help, your great!

4
Contributors
14
Replies
15
Views
14 Years
Discussion Span
Last Post by Forse
0

Run rpm -Uvh mplayer.rpm
And then you should be able to run it by simply typing "mplayer"
No?

0

When you install an RPM where does it go? I am running RH8. I installed 3 rpms and I am unable to find them. Without kpackage RH8 sucks!

0

Try RH9, it's even more "simplified" than RH8! In any case, to the best of my knowledge, RPMs are packages, which means when you install them, they are extracted into all of the files they consist of, which are dispersed throughout the system (in appropriate locations).

Check out a thread here: [thread]378[/thread] and read the post entitled RPM Package Manager. Hopefully it will be of some help to you.

0

Dani,

Thanks for the info. Shrike did not run too good for me. I had problems with Wine and Lotus Notes. The Redhat Package Manger is for Red Hat Packages I think. I did not see any place where there are RPM's. Thanks Again.

0

Maybe I did not explain this correctly. I did not see the packages that I installed. They were not in redhat-config-packages. Sorry for the confusion.

0

You're right, redhat-config-packages only applies to the packages that come with the RedHat distribution CDs.

However, that's not what I'm talking about when I refer you to [thread]378[/thread]

Rather, it's a prior post here on TechTalk that illustrates all about how to use the rpm package management system; how to install, remove, and update packages, how to compile packages, etc etc etc

0

Dani,

In that post you talk about mplayer. That is what I am having trouble installing. I have the command line version working, but I can't figure out the gui. I downloaded all of the rpms for the and installed them, but I can't find where they were installed, so I can't run the gui. I tried to re-install the rpms and it says that they are already installed. Whats up with that!

0

Wait, so I'm confused. If you type "mplayer" into a console, it loads good? So it works now??

0

no, it gives me a list of all of the switches. I would need to type mplayer -playlist (filename). Then it plays the video. I hope am more clear now. Sorry.

0

And then you should be able to run it by simply typing "mplayer"
No?

My mistake. I just tried it and it does the same thing for me. Apparently, that's just the design of the mplayer program ... it can't run without switches. Apparently it needs to know WHAT to play in order to play it.

0

I just found a nice gui program to handle RPMs and it works with RedHat 7.x, 8, as well as 9 ...

Ximian Red-Carpet
available for download here http://www.ximian.com/products/redcarpet/download.html

There is also a subscription service offered by Ximian called Red-Carpet Express where you can subscribe to channels for rpm package downloads.

Hopefully this can be a viable replacement to the late kpackage which was lost after the RedHat 7.x series ...

0

use can istall apt-get for managing RPM (rpm still suck but....whatever) then u can use apt-get to install/remove/fetch rpms

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.