In messages received in Thunderbird I am starting to get strange symbols, such as shown below.

******************
me…Â
The Geezers’ Crusade
*****************
Has anyone else seen this problem? Is it Thunderbird or my machine (iMac OS x10.6)?

Do you have a menu option for "Character Encoding"?
Because it looks like UTF-8 encoded UNICODE to me.

Many thanks for your fast reply. I am still using Thunderbird 2.0.0.23.

Both incoming and outgoing mail default character encoding are set for "Western (ISO - 8859-1)."

In addition to the above, other choices for Western character encoding are:
IBM -850
8859-15
MacRoman
Windows-1252