Well, after something like 2 months, I'm finally able to pull my iBook off the shelf and have at it again. I click the power button, and am ready to go, but for some reason, it hits that loading screen (right after the grey one, but before the login one), the one with the loading bar, that says "Max OS X is starting up...". The bar takes forever (really, like 2 minutes, but that's forever in Mac bootup time...), and when it gets to the end, nothing. It won't move.

I've tried Safe Mode (won't boot normally, can't boot safe mode.), tried Verbose (Doesn't say anything), and everything else I could find, short of running an erase of the harddisk, which I don't want to do if I can really avoid it.

Before I get asked again: No, I don't have another Mac I can connect to to do a Target Disk boot.

Any insight would be amazingly helpfull.:cheesy:

Thanks much,

Perhaps you need to zap your PRAM.

Failing that, I'd say you've got some state of hard disk corruption, and you should probably reinstall Mac OS X.

Did you try booting in single user mode by holding down the s key? Then try typing in /sbin/fsck -fy and if it comes up that it did something keep doing that command until it says it did nothing and shows O.K.
Also it might be a dead battery thing.
Good Luck,

I have pretty much the same problem, left my iBook off for 2 weeks and it wont get past the login screen. I have tried everything, single user mode, disk utility, safe boot, resetting PMU, NVRAM and every key combination there is, and I think I'm going to have to do a reinstall, which will be very tedious as i do not have a full backup of my files and programs. I think it may have something to do with installing some apple updates before i left it. Those things seem to do more harm than good.

I have pretty much the same problem

I had an external 250G drive that was a boot drive stop functioning and it wouldn't even let itself be recognized by any program except Disk Warrior.

Disk Warrior found all the files, rebuilt the directory and saved my files. It worked for me. You might want to try it. It took hours to do but worked great.