I am having trouble running any program that is not made by Mac (with the exception of Final Cut Pro, and Logic Express). The only exceptions for non mac programs are the Native Instruments Suite and Reason 3. The Flash suite, and Photoshop CS do not work. When I click on the icon on the dock it bounces once and just sits there. I've tried reinstalling them but it doesn't work. I have also repaired my permissions as well as verifying my disk. Again, no solution. I am running a MacBook on 2.0Ghz Duo, 2 GB of RAM, 60GB HDD, and system version
10.4.9. They have worked in the past, I can't see why they just stopped working like that.


10 Years
Discussion Span
Last Post by John A

When you drag something into the Dock it creates the Mac Equivelent of a Shortcut. If the Folder that the shortcut is pointing too has been moved then you get a problem like this. My First suggestion would be to remove all programs that are not working from you dock and then locate them in your Applications Folder. Once you have found the program in your appications folder Re-add the program to your dock.


Yeah, Tried it and doesn't work. Neither does the actual program in the Programs folder... :-/

I should add that I just installed Photoshop CS2, and that has not worked at all...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.