0

Ok firstly i guess i should warn you that this post is going to be absolutely gigantic, and give you an overview of the computer im currently running -

It's an Alienware (im not showing off, it was the cheapest one!) which is probably coming up to about 4 years old now so it's quite outdated, but still amazing for a PC of its age.

CPU - AMD Athlon 64 Processor 3200+ - 2Ghz

Memory - 1023Mb

Hard Drive - 120Gb Promise 1+0 Stripe/RAID0 SCS

OS - Microsoft XP Professional

Graphics Card - NVIDIA GeForce FX 5200 Ultra (128Mb)

Sound Card - Creative SB Audigy

I thought i'd better give you all the details i can, because as i've learnt over the years, even the smallest detail can have a massive effect.

Ok so onto the problem(s!)

Firstly it seems as though everytime i find a solution to a problem, another problem arrives which ceases me from solving the first. Then when i set about solving this problem, the exact same thing happens! Times infinitum.

For example.

Something has happened to my Windows installer. Basically it just doesn't work anymore. I can install certain programs, but it seems to be impossible to install or uninstall something which is relatively new or large. Sometimes its impossible to even install old, or ancient programs.

I receive the error message "Windows Installer Service could not be accessed"

So i came across a solution for this on the main Windows site, via countless forums offering the same advice. Firstly i tried re-installing the Windows Installer (how does that work?!) but this had no or little effect whatsoever.

Next i followed an alternative method which involved running the command

"msiexec /regserver"

However this only brought up a new problem, in the form of an error message stating

"An event was unable to invoke any of the subscribers"

Upon setting out to solve this problem, i was told to run

"gpedit.msc"

And then follow the steps

"Administrative Templates/Windows Components/Windows Installer/Prohibit User Installs"

However when i tried to do this i was greeted with the message

"The Following Entry in the [Strings] Section is too long and has been Truncated"

Followed by a lot of garbage, which when the OK button was pressed, proceeded to flag up exactly the same message but with slightly different garbage.

Then upon trying to solve this problem (oh my good God) by installing a fix, i received the error message

"update\update.exe is not a valid Win32 application"

FOR FU- !!!

It seems endless. I thought about giving up there and then, but no, i told myself there would eventually be an end to the madness, and set about solving THIS problem.

But in the end i couldn't find anyone having exactly the same problem as me. There were plenty of people recieving the Win32 error message, but none were for the same reasons, or the same program/file as mine.

And one final problem.

DirectX seems to have randomly rolled back a few editons on me a while ago. Originally i could play Half-Life 2 perfectly fine on my PC, which i think means i must have had at least DirectX 9.1 or even 10 installed.

Yet now when i check what version im running, it tells me im on version 7! And thanks to the Windows Installer problems, i can't install the latest version, or any newer version for that matter. This means im forced to use games and programs from like.. 4 years ago at least, or ones which don't require such a recent version of DirectX.

Please, please, for the love of God someone tell me what the hell is wrong with my computer. If i knew the root of all my problems i could fix it, or at least just a reason why my computer seems to be intent on hating me.

Or is it too far gone and should i just chuck it in the bin? Bearing in mind i don't have the money to purchase a new PC, so would dearly like to repair the old girl.

Thanks in advance for any help anyone can offer.

3
Contributors
2
Replies
3
Views
9 Years
Discussion Span
Last Post by sittas87
0

Why dont you clone your current hard drive do a clean install of windows on a second drive if you have one(or borrow one quick) and do a clean windows installation...and whalla.... all problems solved in one go

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.