0

Here's the short version.
(1) System registry corrupted and computer wouldn't boot. Took it to tech. He found a few bad sectors on HD and replaced it, AND transferred/saved two family users profile accounts & their files to a secondary slave HD on my machine. However, apparently he didn't get MINE because my user account was "password protected." (I always kept my user profile with a password.) He couldn't copy them or move them.
(2) I put the old "bad" HD (with the corrupt registry) into an older computer of mine (as the master HD) and reinstalled XP over the original corrupted XP in the same partition. The recovery console thing wouldn't work, so I had to reinstall XP and it worked great. My original folder called "owner" is still sitting under documents and settings/users. So, the old HD is up and running, BUT I still cannot gain access to MY files. Before all of this mess, my original user account was called "owner." During the reinstall XP setup, it asks me what I want to call my administrator account, but tells me I can't call it "owner"....maybe because there was already a user folder called owner(?) So I named it Jim. Once logged on as Jim, if I attempt to open the "owner" folder thru Win Explorer, I get the "access is denied" popup.
(3) So I go ahead and set up a new user/administrator account called "owner" using the same password as I had before, hoping that XP would automatically link to my old user folder "owner". However, when looking at the user on Windows Explorer,...it showed up as "owner.jim". It automatically added an extension called jim on the end, I guess because there was already an "owner" folder. Still can't access that folder and all of the subfolders in it.

Anyhow, how can I get access to that "owner" folder without having a user account called "owner" to link to it. I know the password and everything, I just can't get it to recognize that it is ME wanting to open it. The only way I know to open folders is thru Win Explorer or logging on as a user and gaining access to that particular users files. Unfortunately, I can't log on as "owner" as it will not allow me to establish a user profile called simply "owner". :sad:

Sorry so long winded, but that's the shortest way I could explain what happened and the steps already taken.

Anyone have any ideas?

7
Contributors
12
Replies
13
Views
12 Years
Discussion Span
Last Post by Jagdfox
0

There is an extremely complicated solution that I know of, but it requires a pretty comfortable knowledge of unix. Do you know Unix?

0

Did you encrypt them or something? If you did, there's not going to be much of a way to get them off, as that's kind of the point of the encryption. But, if it's just a permissions problem, logging in as the real Administrator account might allow access to them.

0

Comotose, I know diddley about Unix. Sorry.

ALC6379, from what the tech (who did the work) says, when you set up a password on your user profile, it encrypts all your data under that profile. But I don't know. It seems a little far fetched. We're talking about 700 digital photos, various spreadsheets, my website folders and files, all my emails, etc. I backed up most (if not all) of the photos, but my last backup of my website was done a few months ago and I've done a lot of work since. I really don't want to recreate the past few months work. I wouldn't think that a password for a simple user profile could create such a problem, especially when you KNOW the password!!! It's just getting the machine and the afflicted folders to realize, "hey, it's me,......here's the password,....now let me in!"

I'm not quite sure what you mean by logging in as the real administrator account. I've logged in as THE only administrator on the machine, but when setting up XP and it's asking you those questions, it would not allow me (the administrator) to call myself "owner"....I'm assuming because there was a password protected profile under the name "owner".

0

You can still have the password to the account, but if the files are encrypted, you're out of luck. The only way you encrypt files/folders is if you go into the Advanced options on your folder and tell it "Encrypt the contents of this folder".

The tech was wrong, though. You can assign a password to a user account, and their data will still be available to look at. Unless it's encrypted, that is. If it's encrypted, only the user who encrypted it (the actual userid, not just the same username or password) will be able to access it. If this is the case, you're going to be in bad shape.

When I mention Administrator, it's an actual account set up by default on your system. There's your names you set, (say, jazzbo, user2, user3, etc), and you can put them in the Administrators group, but the Administrator account has full access to everything on the system, and normally supercedes any file permissions in place on a hard drive. If any account would be able to access them, it would be that one. Some systems, though, only allow you to use Administrator in Safe Mode, which is okay for this purpose.

I think I know where Comatose was going with the Unix bit. If the files aren't encrypted, you could use some bootable LiveCD like Knoppix to access the drive, and copy the data off somewhere else. But again, even that won't work if encryption is in effect. I experienced that first hand, by the way, with a directory I forgot I encrypted. Heck, I don't even know why I encrypted it in the first place... :(

0

there is this way i have used once but it was on the same machine so I dont know if it will work, and it will require usage of a fat32 partition. The reason i found this is becuase I was trying to fiddle around with the permission and I somehow blocked myself (as the administrator & everyone else) permission to a bach of files which i needed. So what I did was i set my account to be a back up operator (or something to that effect) you MUST do this, this gives you permission to temporarily overide security permission while you are "back up" of the files. Once you have created a backup of the files you want, restore them onto a fat32 partition, it will give you some warning about how the security settings will be lost yadda yadda just ignore it since thats what u want in the first place and hopefully you should be good

0

alc6379 ;) knoppix is exactly what I meant (leaning a little toward syphilis, though Phlak is nice too). I also know it's a bit, uh, taboo, but there isn't a tool to decrypt (externally) encrypted folders?

0

You can still have the password to the account, but if the files are encrypted, you're out of luck. The only way you encrypt files/folders is if you go into the Advanced options on your folder and tell it "Encrypt the contents of this folder".

When I mention Administrator, it's an actual account set up by default on your system. There's your names you set, (say, jazzbo, user2, user3, etc), and you can put them in the Administrators group, but the Administrator account has full access to everything on the system, and normally supercedes any file permissions in place on a hard drive. If any account would be able to access them, it would be that one. Some systems, though, only allow you to use Administrator in Safe Mode, which is okay for this purpose.

Alex, I never encrypted anything, folders or files, on my machine. No need. Your explanation of the Administrator account is exactly what I did. I've always been the administrator to my machines. I even kicked my wife off as an administrator when she downloaded "Mickey Mouse's Happy Thanksgiving computer theme" and clogged the machine with spyware. (but I digress) When prompted by XP, I chose Jim as the administrator name, because it specifically said that I could not choose "owner". After I couldn't gain access, I went back and created another administrator account called "owner", but the system stuck a .JIM extension on the end....because there was already a user folder called "owner".

If an Administrator has full access to every folder on the HD, regardless of who created those folders, then there is something else wrong with that folder.

0

there is this way i have used once but it was on the same machine so I dont know if it will work, and it will require usage of a fat32 partition. The reason i found this is becuase I was trying to fiddle around with the permission and I somehow blocked myself (as the administrator & everyone else) permission to a bach of files which i needed. So what I did was i set my account to be a back up operator (or something to that effect) you MUST do this, this gives you permission to temporarily overide security permission while you are "back up" of the files. Once you have created a backup of the files you want, restore them onto a fat32 partition, it will give you some warning about how the security settings will be lost yadda yadda just ignore it since thats what u want in the first place and hopefully you should be good

That sounds like a possibility, but I've never heard of the "back up operator" account. Any idea where I click in order to get a prompt and create a back up operator account?

0

you must be usign windows xp professional,
Open control panel
Open Computer Management
In the console tree, click Local Users and Groups, there ya go!

0

I'm not quite sure what you mean by logging in as the real administrator account. ".

If you start computer in safe mode you will get the option to pick The Real Admin acct created when you installed win xp

0

If it's not too late, I had a very similar problem when I copied and backed up my data folders and then reformatted and installed WIN XP on my computer. Well, I forgot to change the security settings on data folders (I was the only user allowed access). If you are using Windows XP Pro, the solution is pretty simple.

Here is how I fixed it:

Right click the folder you are having trouble with and select Sharing & Security.

Click the Security Tab

Click the advanced box

On the screen that pops up, select the "owner" tab.

Highlight the user you currently are, and check mark the box at the bottom that says "Replace owner on subcontainers and objects".

Agree to everything in the next couple of boxes that pop up and you are in.


Hope this helps you.

Geff

0

If it's not too late, I had a very similar problem when I copied and backed up my data folders and then reformatted and installed WIN XP on my computer. Well, I forgot to change the security settings on data folders (I was the only user allowed access). If you are using Windows XP Pro, the solution is pretty simple.

Here is how I fixed it:

Right click the folder you are having trouble with and select Sharing & Security.

Click the Security Tab

Click the advanced box

On the screen that pops up, select the "owner" tab.

Highlight the user you currently are, and check mark the box at the bottom that says "Replace owner on subcontainers and objects".

Agree to everything in the next couple of boxes that pop up and you are in.


Hope this helps you.

Geff

Your solution worked wonderfully. I happened upon this forum while looking for an answer to the same problem Jazzbo had. I don't have XP pro though so I found out that starting home edition in safe mode gives you some of the Pro edition security options that you mentioned. I was able to get into my folder and save all my data.

Thank you for the solutions posted to this thread.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.