0

Every time I restart my computer it comes up with the little error box wanting to send an error report. It just started 2 days ago.
It says
Run a DLL as an App
Run a DLL as an App has encountered a problem and needs to close. \

What the heck does this mean and do? What do I need to do??

4
Contributors
13
Replies
14
Views
12 Years
Discussion Span
Last Post by cbminfo
0

That error is generated by the rundll32.exe system file, which is responsible for managing numerous other components. To give us a better idea of which exact program/module rundll32 is having trouble with, please click on the "More info" button in the error message dialog box and post the full and exact text of what you see there.

Alternately, you can look at your system and application logs to see if they contain additional information on the error. To view the logs, open the Event Viewer utility in your Administrative Tools control panel.

0

AppName: rundll32.exe AppVer: 5.1.2600.2180 ModName: x10net.dll
ModVer: 2.0.0.40 Offset: 000155b0
This is all it would let me copy.

0

That should do it- thanks. :)

The x10net.dll is a component of the ATI Wonder video card software; it provides funtionality for the remote.

- Have you recently added or upgraded that software (or made any other system changes) just prior to receiving the error message? Give us a little more detail on the history of the problem.

Here are a couple of things you can start with:

1. Completely uninstall the ATI software (and possibly the hardware as well) and then reinstall it from scratch.

2. There are many reports of a bug in the software which will produce the exact error you are seeing. The fix involves editing the Windows Registry, though; you need to be very careful if you attempt it, and making a backup of the Registry before doing so is definitely advised. Explanations of the problem and instructions for the fix(es) can be found in the following links:

http://forums.tweaktown.com/showthread.php?p=222255#post222255
http://www.driverheaven.net/archive/index.php/t-16097.html

And the official word from ATI is as follows:

Regarding Remote Wonder issue:

There are two potential issues that may occur after installing the Remote Wonder drivers. These errors can occur with any version of the driver and affect the x10net.dll file. Both errors appear as Windows loads and occur for different reasons. They appear as follows:

1. 'RUNDLL' error loading c:\progra~1\ATI... The specified module could not be found.

2. Run DLL as an app has encountered a problem and must close.

"AppName: rundll32.exe AppVer: 5.1.2600.0 ModName: x10net.dll ModVer: 2.0.0.40 Offset: 000155b0"


Solution(s):

1. This error is specific to a problem with the x10net.dll path in the registry. The following script can be used to correct the error:

- Click Start, go to RUN
- Type REGEDIT, click Ok
- Highlight My Computer, click Registry, select Export Registry File
- name the *.REG file and save on the Desktop

* if you do make a mistake removing or changing entries then boot to Safe Mode and double click the *.reg file to restore the registry

- Select Edit, click Find
- search the registry for entries containing:

rundll32.exe C:\PROGRA~1\ATI Multimedia\RemCtrl\x10net.dll

and/or:

rundll32.exe C:\PROGRA~1\ATIMUL~1\RemCtrl\x10net.dll

- Right click on Default and select Modify
- Change PROGRA~1 and ATIMUL~1 to Program Files and ATI Multimedia
- Add quotation marks around the path like this:

C:\WINDOWS\System32\rundll32.exe "C:\Program Files\ATI Multimedia\RemCtrl\x10net.dll",EntryPoint

C:\WINDOWS\System32\rundll32.exe "C:\Program Files\ATI Multimedia\RemCtrl\x10net.dll",EntryPoint "%1"

- Click Ok, close Registry Editor and RESTART Windows

NOTE: There are two possible variations of the registry entry; one with and without "%1". Do not add or remove the "%1" if it appears.


2. If above won't work then try the driver from the following website:
- Download the x10drivers.exe file from:
ftp://ftp.x10.com/pub/applications/driver.../x10drivers.exe

- Execute the file to begin installation and RESTART Windows once complete

Be aware that there are other versions of the x10net.dll file which are used by other programs. If you do not have an ATI product installed, please do a search in Windows Explorer for x10net.dll and tell us the full path of the file's location.

0

I have the remote wonder. I can't seem to find where it says click Registry, select Export Registry File I can't find the registry section. I get into the regedit but I am having a tough time finding it after I highlight my computer. I am sure that this is probably the problem. Why can't I just uninstall and reinstall this dang thing?

0

Why can't I just uninstall and reinstall this dang thing?

That was my first suggestion; try that first if you haven't already. It's just that in a number of reports I read on the issue, even reinstalling didn't correct the glitch.

0

DMR I got it. I love you. You are my hero. Why are you so knowledgable? I did have to go and download the driver also. Thanks again. I wish I could return the favor. THANKS THANKS THANKS

0

Glad we could help you get it sorted out! :)

... But please be careful with that "I love you" stuff- my girlfriend uses this forum sometimes too :o :mrgreen:

0

Actually I am a guy so you don't have to worry. Just havin a little fun. And also very appreciative.

0

I also wanted to thank DMR for the info he posted on this thread. Had to join to post it! LOL! I am new to the computer building world, but got one up and running from scratch and it has been fun.
Had this exact problem @ boot up. I have an ATI X700 PRO. Remote software installed, but haven't even used it yet. So,.... I just uninstalled it. No more 'Run DLL as an App' fail. Thank you again, DMR. Take care, Tony. :D

0

Hi Tony,

Thanks for the "Thanks". Appreciation from those we try to help is really the only "pay" that those of who volunteer our time on support sites ever get. :p

0

I've used ATI for years. And never been able to update their catalyst. Screws up everything. So I've stuck with the original installation.
In the past few days, only thing changed I can point a finger at is the installation of CSI 3.
And started getting this x10net.dll app popup.

I installed the driver kit you recommended. Tnx. that did the trick.

But the odd thing is what it installed were files that I've never seen before. Nothing from ATI.
It worked who cares how it works..

0

There probably aren't ATI files in that driver package; X10 isn't an ATI technology. ATI is just one of the video card companies that use the x10 remote control technology with some of their multimedia products.

0

What I'm saying is, the machine worked fine up till a week ago, then it started popping up the x10net failure.
I'd made no changes or additions [thet I knew of] other than the CSI 3 game.
Then this popup starts appearing [actually days after the csi install].
But obviously something changed. Shouldn't have had to install any x10 stuff, but installing that package made the warning disappear.
Last time I had some problem with x10ufx I had to reinstall stuff from the CAB on the ATI disk.
I somehow figured x10 stuff auto deletes itself, or other software does.
I do know I've tried installing many programs that work to disable ATI software. such as Studio V9 +, videowave 8 +, Nero 7, and the list goes on.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.