0

Hi guys I've got a good one.

Colleague brought problem to me, as subject says it's an ACER Aspire 9303 (specs here). The user turned it on (hadn't used it since before christmas) and apparently found out that sound not working. I'm led to believe it worked at some point before Christmas. What you get now in the system tray is the equivalent of "no audio mixers installed" (an X across the sound icon).

The user tried restoring to a previous point but apparently didn't help. I tried installing the drivers given on ACER website (Realtek ones) but it has no effect. Nothing happens after computer is restarted. The account is definitely the administrative account. In Device Manager, there is a yellow triangle on the "Microsoft High Definition Audio..." device. That is the only sound device that's shown. When I check the properties on there, there's a Code 37, which apparently means that Windows cannot initialize the device driver. Which gives me the cause, but no fixes. The only fixes I've seen on the internet is when people have that problem with an optical drive.

I should say at this point, there are also yellow triangles on some other items in Device Manager: the display device (NVidia GeForce Go 7200), the two processor cores (AMD Turion 64 X2 TL-52), and a PCI ISA Bridge or something. Last thing I'm gonna try tomorrow (when next I can get access to the laptop) is d/l MBAM and scan for malware.

Cheers guys!

Oh and for those who are familiar with ACER machines, the Empowering Technology software doesn't work properly either. The bar doesn't have any of the icons in it. I couldn't find where to get it on ACER's website, all I could see was PDFs! Useless!!

2
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by Thinka
0

Hi Thinka,

Those yellow triangles are telling you about a device's current status and normally means that there is a system resource conflict or issue going on between several devices. I do not believe that a virus scan or spyware scan will help you here. You need to uninstall those device drivers that have yellow triangles (one at a time) and install updated drivers for those devices before your sound or other devices will work properly. Search the web for updated drivers from those device vendors.

Good Luck, hope this help to clear up a few things for you and provided you with a little bit more understanding.

0

Hey starfire thanks.

I'm actually not as much of a noob as I apparently sound. I know what the triangles mean, and I have installed new drivers, but like I said up there, they don't have any effect on the machine that's the problem! The machine doesn't recognise that I have installed (for instance) the latest Realtek drivers, whether I run the setup exe, or go through Device Manager and use 'Have Disk' (actually when I use Have Disk, it doesn't find a compatible driver). Most probably because I am trying to find an updated driver for a Microsoft High Definition Audio Device, in a folder containint Realtek drivers :-p

0

Wow, ok guys, quite a few updates to post on here.

Firstly, the sound issue was fixed. It turns out that it was conflicting software (Sybot S&D for anyone interested) that was messing with it. That was uninstalled and the sound came back. That's the good news.

The bad news is, the user then tried to install the Vista SP1 update. Not only that, but during the update, they decided for whatever reason to turn off the computer whilst it was updating (they presumably got tired of waiting). BAAAD MOOOOVE! The well documented 0xc0000034 error.

So as you will read in other cases, an attempted repair yields no result (probably because it was an Acer with no recovery partition drive). The attempt to start windows normally or with the last working configuration yields the afore-mentioned error msg. Starting in safe mode crashes at crcdisk.sys.

To cut a VERY long troubleshooting experience short, I had to look to reinstall Vista as chkdsk with a Vista Recovery Disk wouldn't work so the obviously corrupted harddrive couldn't be fixed thru there, nor could it be fixed by selecting the repair option. In the end the user (luckily) had access to a Vista Installation CD, and decided to use that to re-install the OS. They had their documents and software backed up so there was no issue there. Unfortunately I wasn't able to get a hold of the user to find out how the re-installation went, but I'm sure that was the easiest thing to do, considering all the other things we tried.

My advice to anyone who gets this problem is to try as much as possible to fix the HD (even if it means using an external Disk Repair Utility). If you haven't run the SP1 install yet, do BACKUP before you do. And have an original Vista Installation disc (not just a Recovery CD) to hand. This problem appears to occur with machines that complete the update as well.

Better still if it's an option stay away from Vista and wait for Windows 7 - afterall it will save Microsoft, its customers, and hence the world. :p

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.