0

hi guys,

when my comp was last in vista it said that it needed to run windows memory diagnostic when it next restarted so i schedulled it. Now it runs the test finds no problems but will just keep restarting the test everytime it is done. I have tried to exit and it just restarts again I left my comp on for 24 hours to see if it would get out the loop but it wouldn't.

I can't do anything have tried pressing f8 to get to safe mode or command prompt to dissable it have used bartpe but only xp one to try and open services and msconfig but it cant as they are vista and i cant find a vista pe boot disk. I have put my vista disk in and gone onto command prompt under repair section that wouldnt let me change directory so i could try and run the tools. I have restored my comp to an earlier point but that didnt work.

Anyone know a simple solution.
:icon_confused:
please help

4
Contributors
10
Replies
11
Views
10 Years
Discussion Span
Last Post by JRWilliams308
0

I have exactly the same problem. WMDT just goes into a serial loop and there is no escape out of it.

0

well i havent solved it yet but have just installed vista on another hard drive and taken the orignal one out. But there must be a registary or boot file that can be changed so that it stops it booting into the diagnostic, i know that vista puts all boot info on the first hdd in the first partition but I dont know what to change think i might ring microsoft! also tried deleting the tool in the system32 file of vista so that it couldn't actually run but it was protected and nothing could delete it but it is prob as simple as changing a 0 to 1 in a data file somewhere will let u guys know how i get on with microsoft

0

nope no joy with microsoft they want 46 quid for support as its a msdn program told em to shove it someone must be able to help!

0

I gave up completely and decided to reinstall everything. It was a real pain as I am sure you can imagine.
This is my first ever grievance with Vista and one I have been completely stumped by.

R

0

yep and it seems like no one can help! and as vista wasnt first on the partition it means i have also lost hp and my 500g hdd unless i reformat and lose the data! not a happy bunny!

0

I might have the answer I hope someone is still having the problem so we can test it. First the answer...

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MemoryDiagnostic]
"RunMemDiag"=dword:00000001

and

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability\MemoryDiagnostic]
"LaunchType"=dword:00000002
"ScheduleType"=dword:00000004


Both those keys get modified.

If you open up notepad and paste each of those keys into it including "windows registry..." down to the very bottom. Make sure you change the extension on the file from .txt to .reg

Once thats done double click these files to make the changes(i dont have uac enabled so they might ask for admin confirmation) then reboot.

What I did to find this...

To find these registry keys i used process monitor and had to do a little research for the name of the windows memory diagnostic tool mdsched.exe.

I ended all the processes I could to get anything trying to modify the registry shut down and launched mdsched.exe. Resumed procmon to monitor all registry changes, selected "check for problems next time I start my computer". Filtered all the results for mdsched.exe and then went by hand through every registry key. Most of the keys were fluff in relation to what I was looking for so it was easy to track down the ones you see in the picture there.

In the first key "RunMemDiag"=dword:00000001 does not exist at all after a reboot without running the diag and "LaunchType"=dword:00000002
"ScheduleType"=dword:00000004
Have both been changed to =dword:00000000

Ill attempt to merge those keys and see what the result is. Hope this helps.

Attachments procmon.jpg 277.44 KB
0

Didnt think about this until later but the utility has to have some way of flagging the diagnostic to run before the operating system runs...

0

Actually chris I think I found the real answer to the problem.


Here is where the new editor that replaces boot.ini (which controls boot parameters)

The fix should be done on the command line by launching a command prompt as administrator...

bcdedit.exe /bootsequence {current}

Then...

bcdedit.exe /default {current}

If you get a chance to read through that nice dry paper it goes on to tell you about all the different switches and good stuff bcdedit.exe now does...

Hopefully that fixes any problems anyone might have, and let me know if it does.

0

spendid to find this thread as I thought I was the first to experience this and have been going mad.

One question,how does one run bcdedit.exe fromoutside the windows enviroment? The issuehere is thatwe can't get windows to load no matter whether we hit f8to bypass the normal boot order. Is a BartPE cdthwonly way?

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.