0

This just started less than a month ago.

When I click the Search button in the Explorer toolbar, the following message appears:

"A file that is required to run search companion cannot be found. You may need to run setup."

I am running Microsoft Windows XP Sp3. (finally, I had a tough time installing xp3 and dound out that the registry didn't have the right permission settings)

I have google searched it and it seems like nothing will work. I've tried reinstalling the search thing using Srchasst.inf and it still won't work.

I read this article (http://support.microsoft.com/kb/319949#appliesto) and couldn't install the hot fix since it is for Sp1. I tried the other stuff and still won't work.

If anyone could tell me how to fix this without completely reinstalling Windows XP I'd be much obliged.

2
Contributors
4
Replies
5
Views
8 Years
Discussion Span
Last Post by stevehoff424
0

Thanks for the suggestions. I actually have CCleaner runing at a scheduled time every day @ 3am. I went ahead and tried that reg cure program and fixed like 1369 more problems. Unfortunately, even after a restart, it still won't work.

Like I said before when I first tried to install Sp3, it couldn't install properly. Actually, an error came up that said that the changes that had been made couldn't be reverted either. All the problems that I'm having now started then.

I found out that the reason it wasn't working was a problem with the registry permissions. It was set to allow "Everyone" full access. I had to manually add "System", "Administrators", and my user name (I'm an administrator). After that it seemingly installed successfully. Unfortunately, it was still having the problems that it started having after the initial atempt to install it.

I tried to uninstall Sp3 and while it was uninstalling an error message came up that said "The system cannot find the file specified" "The Service Pack 3 was not uninstalled."


So... umm... yeah. I have no clue what to do with this. I really want the search feature back.

Any help is much appreciated!!!

0

Thanks again for the advice. I saw that on the link I originally posted, but I'm not sure what I did was what I was supposed to do. That key didn't even exist. I made a new REG_DWORD entry named "NoFind" (all the other entry types were that kind) and set the value to 0x00000000 (0). The value type is Hexadecimal. I don't think I did that correctly considering the fact that they describe the key value as follows:
"'NoFind' has the value '01 00 00 00'"

hmmm.... I probably should have tried different entry types...

1 sec....

trying alternative types........

Yes!!! It works! I had to change it from REG_DWORD to REG_SZ.

Thank you for you're help with the search thing!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.