Ok, slipstreamed xp pro installation with sp2, Clean Install, inspects hardware config, asks me to press F6 if i want to install SCSI or RAID Drivers. then to press F2 for ASR, and then nothing, the screen hangs, cd and hard drives go idle and after a short while the keyboard stops responding (lights don't change when pressing caps, num lock etc.)
I know for a fact the cd works, I have another computer in the house I can test things on. Hardware is listed below and much of it is brand new (labelled)

MSI K7N2 Delta-L (nforce2) (Brand new)
AMD Athlon XP3000+ Barton 400mhz FSB (Brand New)
Thermaltake Volcano 9 hs/fan
Sapphire Radeon 128MB 9600XT (Brand New)
Seagate Barracuda 120Gb 7200rpm (Brand New)
768mb DDR 3200 RAM: 1x 512 Crucial
1x 256 Samsung

I don't think anything else is relevant hardware wise? if any more information is needed then I can oblige. I have played around in the bios profusely to no avail. Done the obvious things, fail safe set up, turned off caching, turned off all i/o interfaces, unplugged usb devices, turned off anything i could think of etc etc, still the same.

Any help is appreciated, Thanks in advance.

Is your HDD serial or ide? Have you tried using just one stick of ram?

asks me to press F6 if i want to install SCSI or RAID Drivers. then to press F2 for ASR,.

You don't hit f6 unless you are going to setup raid or scsi .If harddrive is IDE ,just skip hitting any keys until it asks to hit f8 to agreee!!