0

Ok so i am still unable to figure out how to fix my folder problem. I want to go back to the error message: This is no longer in "directory" verify the item's location and try again. What does Microsoft mean by this? what do they expect a user to do with this message?

0

Ok so i am still unable to figure out how to fix my folder problem. I want to go back to the error message: This is no longer in "directory" verify the item's location and try again. What does Microsoft mean by this? what do they expect a user to do with this message?

OK, I'm just sitting here shaking my head at the way these guys have run you around in bloody circles, all with very little idea as to what the hell they are talking about... unbelievable!! The ONLY intelligent response I have seen given was in post #19 in regards to possible protected files within, but even half was nonsense.

Now, before going any further, the critical question to ask is what version of Vista are you running??

Now this is important, as it defines how you activate the real Admin account, not an account with "Admin" privileges. I'll outline both, then we'll look at what is going on... I'm still shaking my head at the NO ONE came even close to the mark :confused:

Like with XP Home, the true Admin account is intentionally made unavailable in Home Premium and below (this is both because you paid less for the Windows version, and also because the "pro" tools extend far outside the realm of the average home user, who is more likely to do harm tinkering with tools they have no experience in, than to use safely). You were nearly there in how to activate, but not quite. FIRSTLY, go into Start Menu and type in the search bar (without speach marks of course) "cmd". As the app shows up, right click and "Run as Administrator" - it WON'T work otherwise, as you are dealing with protected system properties.

Now, I've seen two options for the command promt method, and to be honest, has been a couple of yrs since had to use this method, as I upgraded everything to Ultimate (as will do with Win7), so try either one of the following:
net user administrator /active
or
net user administrator /active:yes

NOW, if you are a good little boy, and have opted for Business or Ultimate, things are MUCH simpler...

Now I always set up my Start Menu to have the Control Panel as a MENU, rather than a LINK.... makes life MUCH easier. Once set, hover over and open Administrative Tools. Go to "Local Security Policy", right-click and run as Admin (will take a little while to load, but perfectly normal, as is dealing with policies all over your Windows installation). Once opened, use the left-side pane to expand "Local Policies", then click on the sub-menu "Security Options" (I'm currently on Win7, but I don't think the names have changed). One of the first policies listed in the main (right-side) pane will reference the Admin Account (in Win7 called "Accounts: Administrator account status", but from memory was same in Vista). Double-click to open the properties window and activate.

After either method, log out and log into newly activated Admin account (of course you'll have the usual wait while it sets things up, but that's neither here nor there). While this is not vital, it certainly makes life a lot easier.

Now, just another correction before I do explain a few things that should have been pointed out from the first response onward!! Of all the suggestions aforenow, ALL omitted one critical factor which prety much ensured NONE of them would have worked, even IF suitable or applicable. ANYTHING CAN BE CHANGED OR DELETED, SO LONG AS THE APP REQUIRED FOR THE TASK IS RUN AS ADMIN. Ie, protected log files can be changed in Notepad IF IT IS RUN AS ADMIN; files can be deleted (even system files - although Windows will often put them back in) if Explorer is RUN AS ADMIN..... I'm sure you're starting to see a pattern here, but same is applicable with Command Prompt. Word to the wise though... if you don't know what you are doing, NEVER use either Command Prompt or Safe Mode to remove stuff, or any other hardcore tinkering, as with either method, System Restore WILL NOT SAVE YOU.

Now, there are SEVERAL possible causes to what is happening, only the least likely of which was covered in post #19, so I'll list as many of them as I can think of at nearly midnight:

1) Yes, sometimes protected folder contents can cause this issue. As you've tried this method and folder remains, we can basically remove this option.

2) Windows has given you the basic answer, when it keeps telling you the folder doesn't exist... IT NO LONGER EXISTS. It is a GHOST folder.... read on for an explanation.

Now, MS actually allowed this problem to be able to occur when they implemented Virtual Folders to assist in backwards-compatibility for older, legacy apps... they actually wrote in folders which ALSO don't exist in any real way. To show what I mean, assuming you have Hidden Folders and Protected System Operating Files both set as visible (via Folder Options), go into Computer > "your system hard drive" Inside you will see the Documents and Settings folder for example... but it DOESN'T EXIST, beyond being a reference to legacy apps who expect it to be there when installing themselves, then Windows takes over from there and redirects.

Now, there are SEVERAL reasons why this folder may be "ghosting" your system:

  • An installed application is referencing the folder
  • your system is referencing the folder (given there were protected files within the ghost folder, either two options are possible)
  • your AV has quarantined - but not deleted - a file, thus either locking out the folder, or "ghosting" it. Check your AV logs to see if this is the case, and either restore the file or delete it.
  • A crappy app uninstaller has removed a program which referenced the folder, but left bits behind, usually in the registry
  • Something else is causing the folder to be referenced within the registry (either of these to options can be sorted out via any DECENT registry repair app, but the easiest and most reliable is CCleaner http://www.ccleaner.com/download
    again, if scrubbing the registry, you should be running CCleaner as Admin

There are actually several other possibilities, has now passed midnight and am just too damned tired to think of the others. Have a look at the links below for further info... ironically, Outlook and AVs keep popping up as the two biggest culprits. Also, have included an advanced Google search to give you more info on ghost files/folders.

At the end of the day, you may simply not be able to locate the cause and successfully remove the folder. At the end of the day, it is not going to do any harm and you have to decide just how much effort and time you want to expend on trying to remove an effectively harmless and useless ghost folder :-/

http://www.vistax64.com/vista-mail/177087-ghost-emails-delete-folder.html
http://forum.xcitefun.net/create-a-ghost-folder-in-xp-and-vista-t13651.html
http://www.pctipsbox.com/create-a-ghost-folder-in-xp-vista/
http://outlook-tips.net/howto/ghosts.htm
http://outlook-tips.net/howto/ghosts_mb.htm

http://www.google.com.au/search?hl=en&rlz=1G1GGLQ_ENAU336&q=%2Bremoving+%2Bghost+%2Bvista+folders+files+-norton+&btnG=Search&meta=

0

Ok so i greatly appreciate your long post.

So i am running Vista Home Premium...sorry im not a good little boy after all...but i am quite sure i have already activated the real admin account. i used another forum website to do it and it was a while ago so i could not tell you exactly how i did it. So lets say i did. and go from there. Will your post direct me in the correct direction running home premium?

0

You can try most tactics even without the Admin account, but it does make life easier, and yes, it should still set you straight in Vista HP :)

0

Okay i will try out your methods and let you know, who knows if all my problems are connected..lol

0

At the risk of getting another blast from kaninelupus, you can run Explorer.exe in Admin mode and then do the things you've already tried perhaps not as "real Administrator".

What struck me as particularly sensible in kaninelupus' list of suggestions was the notion of a ghost directory quarantined by AV. If that's the case, then the AV program can usually be told to delete what it has quarantined.

Did you try the file unlocker? Also, the hidden files you encounhtered - do you remember anything about them, like what they were called and their creation date?

Details are important wherever possible.

0

So like i have been saying in all of my threads...i went with the system recovery and started from scratch. I appreciate everyone's help as i attempted to fix my folder problem myself, but there were too many problems all at once. All your help did not go to waste, i appreciate learning all i can from you guys.Thanks again.

0

Glad you're sorted. Perhaps you can mark this thread as SOLVED.

Agreed, although sad that it took such drastic measures. As a tip, rather than running a restore, might be worth investing in a retail copy of Windows (or even Win7 RC builds - yes others have become "available" since RC1... and I don't mention this to support questionable methods, but to illustrate build closer to final release till actually purchasable) as will run cleaner than anything preloaded on an OEM system, and ultimately give more reliability and end-user satisfaction :)

NB: Have actually found - much to my surprise - that in moving from Vista Ultimate x86 to Win7 x64 (well moving, as in dual booting but not actually needing to load up in Vista since the install of Win7), my hardware runs better than either XP or Vista, and performance even leaves XP in the dust. Drivers are easy enough to DL from OEM sites, and should give you a much better experience than running a restore to reinstall an OS bogged down with the usual OEM "customised" build, loaded with crap.

Just a thought :)

0

.....better experience than running a restore to reinstall an OS bogged down with the usual OEM "customised" build, loaded with crap.

Just a thought :)

One of the problems with Toshiba Qosmio (I think that's Nickair's system) is that there is a lot of special hardware like, in my case, the Quad Graphics Upscaler. Also, possibly, the fingerprint reader.

So some thought about this is necessary when diverging from the OEM supplied OS.

0

i ended up resetting my comp to factory settings a while ago...fixed this issue. Thanks for everyones input.

0

you may try to restore your system to a time prior to when the drag and drop issue occured.

Here is information on system restore:
Running the System Restore utility…

1. Click Start, click All Programs, click Accessories, click System Tools, and then click System Restore.
2. Click Continue or provide Administrator credentials if necessary.
3. Click Choose a different restore point, and then click Next.
4. Select a Date and Time prior to first sign of the issue you’ve described.
5. If the date you need is in excess of (5) days click the Show restore points older than 5 days check box.

0

An easier way to delete it would be with command promt, ive gotten myself in this mess before playing with nameless fodlers.

You need to click start then run or search fro run if you are on vista or 7 then type command prompt and press enter navigate to the folder

Then to delet it type rmdir "the folder name" /s and press enter... if this does not work you will need to delete the folder above it.

If you dont know how to use command prompt jsut send me the full path of the folder and send you the full command line to run.

0

hi, i am having the exact same problem...
the *problem* 's path is :

C:\Users\al-tay\Desktop\pics..

please tell me how to delete from command promt..
thank you !

0

I had the same problem. I was able to delete the directory, even with the hidden files (or phantom files).

From the command prompt use the rmdir command (remove directory); but you have to use the /s switch (the "s" will remove all sub-directories and files)

In my case the troubled directory with the phantom/hidden files was my "windows.old" directory. The following is the syntex I used.

C:\>rmdir /s windows.old
windows.old, Are you sure (Y/N)? y

It worked for me, give it a try.

0

To swvierr,

Thanks for sharing your method, unfortunately it still cannot work..
it says : The system cannot find the file specified. (SIGH)

0

im haveing the same problem i downloded a program then i deleted it off my account but when i go to the main account on my windows 7 computer the folder is still there i move it to the trash but it comes back every cupple of minutes HELP ME i hear alot about uing f8 and safe mode but im not sure about that HELPPPPPPPPPPPPPPPPPPPP

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.