0

I have got a really nasty virus on my PC, I have used the dell sytem restore to restore it back to factory settings as this has worked with other virus probs, but when I restart its still there, on the black bios start up screen it has green lines accross the screen and won't start windows...I was hoping there was a floppy disk or something i could start the pc with to format it clean off the virus?

2
Contributors
7
Replies
8
Views
7 Years
Discussion Span
Last Post by kennyn
0

If the Bios screen is showing lines across the screen then this is probably not a problem with a virus in Windows.
More likely to be a problem with the pc.
What symptoms did you have that suggested you had a virus ?
Can you get into the bios settings pages ?
And if so do the green lines go away ?

0

Hi, thanks for the reply :) basically i uninstalled the mcafee virus protection as was having issues installing something, and an hour or so later i was online and all of a sudden the screen froze with lots of wierd colours and the shut down, once i restarted it was there from immediate start up.. I have been able to get into the bios settings ( blue? ) pages, but its still there, and also sometimes i cant choose certain options like the sytem restore as the mouse would stop.. i managed to get into windows safe mode too and restore to earlier date, but no matter what i do, the colours are still there preventing me from seeing what im doing properly and preventing me from running windows in normal mode at all... it seems like its a virus that is there from start up if there is such a thing?

0

It is possible to get a boot sector virus which might explain some of this.
But not the screen being corrupted when in the bios settings
( At that point you haven't got as far as reading the hard disk )
It still sounds more like a hardware fault or possibly corrupt bios settings.
To check this, go into the bios and disable the hard disk.
The pc will then not to boot to Windows, but at least it will proves the issue more low-level than a virus on the hard disk.

0

ok, great, good idea, but how do I disable the hard disk in the bios?

0

I hazard guess from most Dells I've seen it will be -
F2 for the bios setup
Look inside "Drives"
It will probably be the first drive listed e.g. Drive 0
If it set to "On" and has a disk attached it will give you the drive details on the right hand side.
Once you've found it, press enter, then change setting to off.
At this stage it won't do any harm to switch all drives to off to be sure.
Although make a note of what the bios says is connected to each in case you want to switch things back on selectively later.

0

Ok, thanks for this... i'll take a look tonight, and repost, thanks for your help..

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.