0

Hey guys.
I recently bought an HP 620 notebook and i decided to partition it. I managed to partition it into 3 drives with the 4th being the recovery.

However, i have not been able boot it as it can not load windows directly. When i start it it loads bios and then shows a black screen with a small blinking underscore on the far left of the screen and this continues forever.

I have been able to make a boot disk on my USB memory stick and have been using this to boot the computer successfully. I have also noticed that when i explore the computer through Acronis Disk Director (which i had hoped will solve the problem) i see an extra 300MB disk named SYSTEM in addition to the SYSTEM(C), HP Recovery(D), MEDIA(E) and DATA(F). This extra disk does not have a letter on it and i cant see it on my computer from windows explorer.

I also tried to use a Windows 7 disk from a friend (since my pc did not come with disks)to repair installation but this has not worked also. It just showed me something about an active disk and i ran repair but did not solve the problem.

My antivirus sometimes gives me a warning about an active boot sector but it also cant solve it.

I will appreciate any help as i am sick of using the USB to boot my pc, especially that it is new.

Regards

4
Contributors
6
Replies
7
Views
6 Years
Discussion Span
Last Post by crunchie
0

Firstly have you stored a restore point if so than you can restore your system to previous point.

otherwise i dont think that you are left with much option only a clean install of windows will solve the problem.

0

You have probably deleted the 100Mb partition with the boot files on it. A system repair should fix it. What happen when you try it?

0

Thank you Kundan and Cruchie for your replies.
I think the restore point could have worked but somehow when i try it, it shows a restore point just after this incident has happened. I considered installing a new windows as a last resort and if i can not fix this i will then install new Windows.

When i run the repair it tells me that the repair was done successfully but then the problem is not solved. The partition with the boot disk is there but i think that is exactly where the problem is.

I think that the partion changed the disk orders and locations such that when the mbr in the small partion runs it directs the boot records to a disk that does not have windows because the partitions moved everything around.

I will be happy if there is a way of using the function like 'fdisk' that was useful in xp for win 7 to direct the boot disk to the proper boot drive with with windows. I also hear that i can use a cd with linux boot files to direct the mbr to correct drive with windows but Linux is alien to me, but a clear step by step will help.

Thus, i am losing for a way to direct the mbr to the correct drive with windows and if you think this does not work or there is no such way then please advise me.

Edited by achemura: n/a

0

I think you are absolutely right about where the mbr files are or not. It is worth using one of the partition disks to find out if the primary partition is marked as the boot partition. That is the first step to establish (or at least one and only one of the partitions is marked as boot) then the mbr has to go on that partition.

Using repair should put the mbr back but if it doesn't there are other ways. it can be done from dos and I believe but cant remember what it is (and google will help here) that there is a command in windows to restore / replace the mbr.

Using a linux bootable CD is actually quite easy and there are instructions that are fairly simple to follow and I have found it a great help so do not be afraid it can be a lifeline as well as a learning experience!

M

0

Thank you very much. I will explore the options and give feedback.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.