Hi everyone,
Running: Windows 7 Professional (64 bit), MS Office 2010, IE 9.08.... since I bought the laptop in September and have made no software modifications at all.

Having a really annoying problem. Have searched web and here. Whilst sismilar issues are out there, I can't find one the same as mine.

When I try to follow hyperlinks in MS Word (including links in TOCs) or PDF documents I get the follwing error message:
"This operation has been cancelled due to restrictions in effect on this computer. Pls contact your system administrator.

I don't have any problems following hyperlinks from IE itself and can surf without any problems and IE is already set as the default (I don't have other brwsers).

Solutions on the web seem to realte to MS Outlook or to having set a browser other than IE as the default and relate to changing the registry.

Because I use this machine for work I did not want to risk changing the registry without getting some confirmation as to what to exactly do. Plus I don't understand how following a link in a TOC in the same document relates to an IE setting.

One solution presented on the web call for the data value of the following key,
HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command, to be set to "htmlfile"

The value for this key on my machine is:
"C:\Program Files (x86)\Internet Explorer\iexplore.exe" -nohome

Another solution says that the data value of HKEY_Local_Machine\Software\Microsoft\ Windows\CurrentVersion\Explorer\StartMenu\StartMenu\Cascade\ControlPanel\Policy\ NoControlPanel, should be set to "0"

The value for this key on my machine is: "(value not set)"

Obviously I am happy to make a registry change to fix the problem but need to know exactly what to do. If the first solution is correct then do I just delete the entire value and replace it with "htmlfile".

Your assistance will be greately appreciated.
Thanks in advance.
Zeki

Hi everyone,

I found a fix for my problem and thought I'd put it here in case anyone else had the same issue. Please note I am running Windows 7 Pro (64 bit).

  1. Go to: Control Panel\Default Programs\Set Program Access and Computer defaults
  2. Click on: Microsoft Windows (mine was originally set to "custom").
  3. Click on: OK

This worked for me.

For some reason though after restart the setting goes back to "custom" but the issue does not come back.

Cheers
Zeki