My internet browsers and internet browsing related software (such as updaters and uninstallers and installers) just won't open...

I only have two internet browsers Firefox(Mostly used) and Google Chrome.

Everytime I try to open it, the cursor will turn into the "Working in desktop" cursor for half a second to 3 seconds...

I tried to monitor the process in the Task Manager...

firefox.exe or chrome.exe will appear for half a second to 3 seconds in the processes but not on the running applications. Memory (Private Working Set) is random but in between 300K-500K. Same goes for the updaters and installers.

All my online games work. Updating other software without the browser also works.

I am running on Windows 7 Home Premium

on an HP Pavillion dm 1 laptop.

I have no antivirus software whatsoever (aside the ones that came with the computer. But it was the kind that was just for the money). I have always dealt with viruses on my own.

I assume though that it is a sabotage virus... otherwise a simple computer error...

i have tried most of the solutions posted on this and other sites but none work.

Pinging websites work with successful replies.

netsh int ip reset reset.log - failed saying I should run it as administrator even though I am on an administrator account. And that there are no user specified settings to be reset.

netsh winsock reset catalog - was successful but did not fix any problems nor made any visibile change whatsoever.

My internet browsers and internet browsing-related software won't open in Safe Mode either.

I humbly ask of your assistance as I am in desperate need of help.

Thank you in advance.

Might not be the first time somebody has suggested this, but have you tried running them in Compatibility mode?

Run Malwarebytes and then Superantispyware. Let us know how you get on.

You're really asking for this kinda trouble by not having an AV. My personal favourite is Avast. :-)

"netsh int ip reset reset.log"
should be... netsh int ip reset resetlog.txt

Or I guess that doen't matter. reset.log is just a file to write to.
I hate networking.. too complex.

@colliebob... As I have said, I cannot open any internet browser-related software such as updaters and installers... surely that includes safe mode and compatibility mode... I tried anyway but still nothing...

@Bigpaw Malwarebytes removed a lot from my PC but one of them seems to stick around my AppData\Local\Temp folder... everytime I delete it with Malwarebytes, it just comes back with a new name but same format as a .tmp file... latest one is ppa9896.tmp... but like I said... name keeps changing...

I have also tried Super Antispyware but it won't open...

@Caperjack... just like Malwarebytes... rogue killer removed stuff from my PC... The registry is clean now... but doesn't fix my problem...

@gerbil... well... I just copy-pasted that from a different site... All I did was netsh int ip reset... then restarted my comp...

[UPDATE]
I was able to get netsh int ip reset to work... but to no avail... the problem stands...

[UPDATE]

I solved it. All I did was replace the Mozilla Firefox and Google folders with ones from another computer...

But thanks anyway for all your input...