0

Hi,
I have a PC running Windows 8. Every time it boots up it tries to 'Scan and repair disk errors on C:' but never gets above 0% - i.e. it hangs at the very start of the process. The 'circle' icon rotates so it is not that the whole PC has frozen - it's just that the progress never gets above 0%. If I reboot it and manage to 'press a key within one second' to skip the disk check, the PC boots up normally, and I can log in to W8 and everything appears to run properly. I can access emails, my documents, get on the internet, play games etc etc. PC remains on and stable for at least 2 hours. When I next turn on the computer it tries to run chkdsk again, and again hangs at 0%. I have left it scanning overnight, but it still doesn't progress passed 0%. I have tried running 'chkdsk /spotfix c:' and rebooting, but it doesn't appear to do anything different (still stops at 0%) but I don't know how to tell if it's doing the spotfix, or still trying to do the full scan

Is there a way to either a) stop it trying to run chkdsk every time, or b) get it further than 0%.

The PC isn't mine, it was brought to me for repair, so I don't have any background on what was happening when this first started. PC is a HP Pavillion and less than a year old, but I don't know much else about it.

Many thanks,
Toomutch

3
Contributors
2
Replies
7
Views
3 Years
Discussion Span
Last Post by shdwmage
0

It seems there is a subtle corruption of the file system, but not one that keeps the system from running (at least for now). Boot it up, and copy your critical data to an external drive, then either restore the system from the system restore partition (there should be one on the disc), an installation disc, or alternatively, boot a Live Linux CD/USB/DVD drive, and try to fix the NTFS partition with the fsck program that Linux provides. In any case, try one or both of the first 2 suggestions first. As an IT consultant, I would go for the third, but by first removing the drive, and installing it in my Linux system as an extern Sata or USB drive - not advisable for non-experts! :-)

0

You can try "chkdsk /f" from an administrative command prompt and reboot.

You should be able to clear the check disk flag from msconfig.

Alternitevally you can boot into the windows recovery console and try manually running the commands there.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.