Firefox is default browser but Thunderbird email links
have stopped opening in the browser in the last few days.
Have tried most of Mozilla's recommendations but nothing
has worked so far.

Many thanks.
Followed your suggestion but I am afraid that it made no difference.
Firefox is set as the default browser and Thunderbird is set as default
email client.
This problem has been going on for a little over a week now - must be a record for me for fixing an issue - but there is no sign of a solution yet.
Very much appreciate your help.

What happens if you try it from a newly created Windows user account?

Sorry for delay in getting back.
I don't know how to create a new Windows user account.
Also, would I be able to go back to the old one?
How would it affect using other Windows machines?
Thanks for response.

To create a new Windows user account, open a command prompt and type 'control userpasswords2'. The 'User Accounts' dialog box should appear. Select the Users tab and click the 'Add...' button. Alternatively you can find the dialog box through the control panel, or follow Microsoft's guidance: "Creating a user account"

Once you've created the user account you should be able to switch between them by logging off and then on. If fast user switching is enabled (not available on lesser editions of Windows), you can switch between accounts without having to log off first.

Creating a new user account will give you a fresh Windows user profile, and running Firefox will generate a new Firefox profile. If Firefox works as expected that would suggest your installation of Firefox is fine, and also the profile for the Windows user account.

As a next step you could try copying the old Firefox profile across to your new account. Note there will be some file permission issues when attempting to access the other user's account, so you'll need to copy the old profile to a shared location or grant the second account permissions to access the old profile folder.

To find the location of your Firefox profile open up the browser and navigate to 'Help > Troubleshooting Information' > Profile Folder.

You'll need to edit 'profile.ini' to tell Firefox where to find a copy of the old profile. The ini file is normally located in the user's AppData folder, typically something like C:\Users[USER]\AppData\Roaming\Mozilla\Firefox.

Run Firefox with the '-ProfileManager' switch and you should be able to choose which profile to load.

If the old Firefox profile works with the new Windows user account, but still shows the same fault, then it suggests a problem with that profile. You might be able to deduce what the problem is by comparing the bad profile with a working one. Bring the profiles closer together, for example by adding in any plug-ins or extensions you use, one at a time, and hopefully the fault will become apparent.

Good luck and let me know how you get on.

Gosh!
What a huge amount of work you have put in.
Really appreciate your efforts.
As someone who is very much a novice this is going to take
some time.
Thanks for the good wishes, for all the work, and will let you
know how things go.

    You can try to clear your browser history. Open FireFox and then click "Settings" > "History" > "Clear browsing data". quit the browser and sign in it again. At this moment, your email links may become normal. 

Afraid that didn't work.
Was worth a try, though.
Thanks.

Have tried most of Mozilla's recommendations but nothing has worked so far.

Techno, it might be worth trying a few more. Millions and millions of people use Firefox so it's quite likely that someone else has encountered the same problem or something very similar.

Have a look at this one on Mozilla's support forum: http://support.mozilla.org/en-US/questions/921787 Please check the entire thread as it contains some info that's related to how mailto links work in Firefox.

I think my earlier troubleshooting advice is a little to involved for a novice, but it's something you might want to return to later on if you do get really stuck. Once you've identified the fault I suspect the fix will actually be quite simple. Keep trying :-)

Many thanks.
I did look extensively at Mozilla's site when the problem first started about a month ago but I will go back and check again in case I missed anything
I will most certainly return to your earlier advice at a later stage.
Yes, indeed, the fix will probably turn out to be quite simple.
No sign of it yet, though!