0

my pc cannot locate the boot.ini file?
pc cannot find the boot.ini file and is not loading my normal desktop settings. I have lost most of my icons. My pc no longer asks me to logon. I am running Windows 2000 professional. Would appreciate any help, thank you

4
Contributors
5
Replies
6
Views
10 Years
Discussion Span
Last Post by gerbil
0

First, exactly what error are you getting? How do you know it can't locate the boot.ini? Was the error?:

Invalid Boot.ini

Windows could not start because the following file is missing or corrupt:

Windows\System32\Hal.dll

If so, there could be several reasons for that, and a missing boot.ini is only one of them.

Second, have you booted to CD and checked to see if the file exists on your C: drive (the default location)? If the file exists, have you examined the content to make sure it is correct?

Third, have you tried using the Recovery Console on the CD to restore the boot files?

0

First, exactly what error are you getting? How do you know it can't locate the boot.ini? Was the error?:

If so, there could be several reasons for that, and a missing boot.ini is only one of them.

Second, have you booted to CD and checked to see if the file exists on your C: drive (the default location)? If the file exists, have you examined the content to make sure it is correct?

Third, have you tried using the Recovery Console on the CD to restore the boot files?

When I boot my pc the black dos screen appears with the message:
Invalid boot.ini file
booting from c:/winnt/ then it goes to the desktop, but not with my icons. Also it does not ask me to log in. Any help is appreciated.

0

When I boot my pc the black dos screen appears with the message:
Invalid boot.ini file
booting from c:/winnt/ then it goes to the desktop, but not with my icons. Also it does not ask me to log in. Any help is appreciated.

0

boot.ini file is normally in the c:\ root directory. In Explorer turn on the option to see hidden and system files if you need to, then check the root directory to see if it is there. If it is, send it to Notepad and paste the contents to your respose in this thread so we can see it. Make sure you do NOT change the contents of that file!

0

...you will also have to uncheck "hide protected operating system files" under explorer folder options/view. Then open a clean notepad, and drag C:\boot.ini into it. Then you might go back and recheck that box...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.