0

I'm using windows 2k adv serv and running iis 5. I want to run a small web server, but i can't get it accessed through my firewall (linksys wireless 4prt switch). I think the problem is something to do with making the app run in passive mode. Any ways that i can do that or any suggestions on how i could make it work through the firewall. I tried via my network, it worked fine, therefore it's my router/lan settings on iis.

7
Contributors
17
Replies
21
Views
15 Years
Discussion Span
Last Post by funkdat
0

I know the answer to your problem. Set your website to a port other than 80. FYI.. most websites are on port 80, so when you type in http://www.msn.com, its really http://www.msn.com:80. Optimum Online blocks all incoming port 80's. The way you access your site is http://url:port .... or you can get something like dns2go and they have a place to make it automatticly go to a specified port.

0

Guess I gotta add an ftp and http server section to my Networking and Internet section, eh? ;D

0

It's not...

why does optimum online block it!i thought we were uncapped, as in NO restrictions.

c... there's an !, that signifies an end of a sentence

0

:) Answer #2. Access your Router by going into DOS or http:

DOS Way. Type 'telnet 192.168.0.1'

User Name: admin (default)
Password: 1234 (default)

Open up your port for that internal computer. Find the IP of that computer by typing in DOS 'ipconfig'

so set your router/hub to this 192.168.0.2 80
example that computer's IP is 192.168.0.2

The Internet Explorer Way. (easier)
type this in IE
http://192.168.0.1

it will access your router/hub. Configure it there.

0

I think the fact that you have to include a port number when you're using IIS in your URL with another port other than 80, is just because of Microsoft. I haven't found any other way to get around it(if anyone has any info, I'd appreciate it).

I have heard from several people that Apache has a way around it. It doesn't seem like a complicated thing either. I don't think it goes down to an HTTP protocol layer, so I don't see what the problem is.

0

Problem is... i can access it via my network, typing in both:

http://24.24.24.24/website (cable modem ip)

and

http://192.168.1.101/website (network ip)

from within a computer in my network. So i think it's the router, not iis. And apache, can't use, i have asp on da site. I don't want to use that asp thing for linux cause there are some stuff i'm doing in asp that it doesn't support.

0

If it is a Router can you no matter what name brand. Also you should call them Linksys and ask them they will solve your problem in no time.

Also you can use a Serial Cable and use a thing windows comes with called Hyper Terminal I hope I spelled it right and access the Software or Hardware Software on the router something to think about.

0

Where would i connect the serial cable to? in my router (linksys wireless wit 4 prt switch) has only a place to plug in cable modem, 4 ethernet ports, and two removable wireless antanaes.

0

Where would i connect the serial cable to? in my router (linksys wireless wit 4 prt switch) has only a place to plug in cable modem, 4 ethernet ports, and two removable wireless antanaes.

DOS 'telnet 192.168.0.1'
or
http://192.168.0.1

user name: admin
password 1234

dude you have to try you might have a Router/Hub.
promise me to try.

http://www.deerfield.com

Download there program called "Web Site" you can pick the port without a problem it's the best man i tell you.

IIS sucks compared to there version.

0

I'm downloading nw @ 250 KBPS and rising. I don't have time figuring out the program, gtg soon, but what does it do?

Also, i have a router/hub. The full name of my router is, "Linksys Wireless Router with 4 Port Switch". The telnet doesn't work, but i can go into internet explorer and type in

http://192.168.1.1
pass: admin
no sn

and get access into it. But it's not my router, atleast i doubt it. I can access the site via port 80 from laptop -> router -> desktop, but not from friend computer -> internet -> router -> my computer. Tek says it's optimum, and when i switched to another port, it worked.

0

you could try opening up port 8080 on the router as that will most likely be blocked there right now.. and then setting that for the port on the webserver... as if i remember correctly, IE will automatically check 8080 if nothing shows up on 80.. or.. you could make it a secure site, and be on port 442 or something like that.. dont remember the port right now.. but chances are it is optimum online.. as even though its "uncapped" its still suppose to be for home use.. ie.. no servers.

0

i had the same problem, ensuing in a big headache one day I couldnt figure out why i couldnt get anyone outside my LAN to access IIS 5

then i used port 81 and it worked....

i wouldnt be surprised if optonline blocked the web port

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.