When I try to add new folders to the My Music folder, I can't name them-- they are all called "New Folder (X)"-- nor can I rename them. I've gotten around this by making folders on the desktop and pasting them into My Music, but it is a bit of a pain. Also, when I right click the new folder in an attempt to rename it, the name box is greyed out.

Lauren :)

Err, I forgot to add that I'm running XP home, with all the service packs available installed.

So when you press F2 when you have the "new" folder selected, Windows does not allow you to rename it? It does nothing? A beep even?

How are you logged into you system? Do you have administrator status? Do you have this problem anywhere else? (I know not on your desktop, but I mean elsewhere).

Right click on the file then go to properties, check to see if the hidden option is set. This will not help you with the folder renaming but it might be the reason that your files are greyed out.

I sort of fixed the problem, mostly just went around it. The shortcut on my desktop, and consequently where I saved all my music, was mapped to my recent documents, and I just changed it to the regular my documents. I can rename now; I'm not sure what the problem was before, but I've fixed it.

Thanks for all of your help, Paladine and JR85023.