0

Hi,

Yesterday I had the worst possible nightmare; my 2 year old Sony Vaio laptop running on WinXP Home gave me an error dialogue box on start up, it reads:

Explorer.EXE - Application Error
The application failed to initialize properly (0xc0000006)

When I hit “OK” Windows starts up, however I see nothing on my desktop, no start menu, etc zilch… I tried ctrl+alt+del and ran the task “explorer” but I got the same error message above.

Now, I tried http://www.myfixes.com/articles/wininet (found on DANIWEB) resolution but unfortunately I hit a brick wall when I realized that I get the same error (above) when I start in all Safe Modes, therefore I can’t run any possible diagnosis or even backup what I have on the laptop to prepare for a full format!

I’m not sure exactly what the error is related to, is it a virus? Or is it WinXP just being Microsoft? I don’t know – please help!

If worst came to worst and I need a complete format (which I’m trying in vain to avoid) is there anyway I can back up what’s on the C:/ Drive without going through Explorer?

Any help would be much appreciated!

Thank You.

6
Contributors
9
Replies
10
Views
10 Years
Discussion Span
Last Post by Jhicks56
0

Well, about backing up, you honestly have only 1 option here if you can't load Windows...The best thing you can do to backup without fixing your EXPLORER error is to remove the hard drive from your computer and SLAVE it to a WORKING computer and then copy the files either to CD, DVD, or another Hard Drive. I'll work on finding a resolution for your EXPLORER error though ;-)

0

Thanks Joshua,

I have limited knowledge on PC Desktop components, so taking apart a laptop would be seriously out of my league... I have searched high and low on Google and Microsoft for a fix, but no one offers a complete solution. If you find anything it would be extremely welcomed!

Cheers.

0

Ok, looks like you can get into Advanced Startup Options [cos u got to the safe mode options..], so try Last Known Good Config [which is saved when windows last did a successful shutdown]. One other thing, since when u have the blank screen you can get task manager up, in the Run box paste this:
%systemroot%\system32\restore\rstrui.exe
-that will give u access to your restore points. Let us know how you go...

0

Hi Gerbil,

Sorry I should have documented this in the original post, I tried the "Last Known Good Config" option which gave me the same problem.

I just tried the system restore via the Task Manger, at first I got an error dialogue box, saying something about memory, but then the restore dialogue popped up behind it, I restored the laptop to a check point I knew was ok, but unfortunately after the restart I got the same error...

Cheers.

0

Hi,

I almost gave in and decided that a restore was going to be the only solution, but I still needed to back everything up, I used DOS Backup and Copy commands to do this.

After searching DaniWeb one final time I found Gerbil’s post on another thread:

http://www.daniweb.com/techtalkforums/thread63720.html

Which said to try and run the following command in Task Manger (or RUN):

sfc /scannow [note that space after sfc !!]

I did so and after a long wait whilst Windows checked Windows files I restarted and what do you know everything seems to be working as per normal!!! You’re a life-saver! Nice one matey.

Just about to run a few spyware apps, just to double make sure.

Hope this helps others.

Cheers

0

hi, janj, great stuff and thanks for returning with your fix, and for the pat . You don't have that trojan problem referred to in that link you mention in your first post - you had a real break in the software [the trojan puts up a false warning, breaks your desktop to scare you, and then sells antispyware - pretty much the sys keeps working. Well, it has to so it can sell stuff..].
Bit of sfc background :

[sfc checks protected files being used by the sys for any overwriting; if it detects that it copies in new files from the dllcache; if the dllcache has corrupted files it asks for the CD.... but it beats me why the cache gets corrupted - i always have to load the CD...]

0

I'm having the same problem on this computer, the only thing I can bring up is firefox... how'd I get that to happen? I snuck it before I got another error. I have another problem though, seems that my computer is not only getting the error but on top of that the computer's DVD rom is going out and guess what... IT'S a laptop! So I'd have to buy a new, EXPENSIVE, dvd rom just to get anything working... But the dvd rom is reading my windows xp disc as a BLANK DISC... So... I'm screwed. I can't even get into system restore in bios or cmos... any answers?

0

ActiveMovie Window:explorer.exe - application error
The instruction at "0x04d2321f" referenced memory at "0x00000000".
The memory could not be "written".

0

HERE is THE FIX: Run the instructions above to attempt to restore
To an old point (it will not complete but u have to do it) then shut down- restart
With pressing F9 at start up- let the DiskCheck run-
It will fixed the errors. Your OS will start up without the error and it will complete the restore at that time.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.