When I run the installer for Safari 3 (Vista), it gives me an error (screenshot).

Anyone wanna help?

What version of vista do you have?
Are you logged in as an adminsitrator?

Try downloading safari again. Maybe it is damaged.

Also try installing in xp compatibility mode

I have:

Vista Home Premium
My "Alex" account has administrative privileges
I have redownloaded Safari a bunch of times
I'll try compatibility mode...
EDIT: Didn't work. I have no idea what's wrong, and I don't feel like contacting Apple (because of what happened when I tried contacting them about iTunes......).

Any other ideas?

Error 2738 is an error relating to VBScript being disabled or not installed. A quick Google reveals some folk have had problems with it during QuickTime/iTunes installs and points to an Apple support doc here for help.

Basically suggesting you ensure it is enabled/installed and if still having problems install the latest VBScript engine for Windows.

FWIW I installed the Safari Beta on Vista without hassle, so it is not an inherent problem with the Safari installer.

How can I enable VBScript under Vista? I've never had experience there...

I tried disabling "UAC" to make it work without any luck (I did reboot). How else can I try to enable VBS?

What version of vista do you have?

Vista Home Premium. I already said that in my first post...

Never mind, got it installed. I went up to my moms house and ran the installer again and it worked somehow...

Thanks though.