0

Hey everyone. I'm having trouble getting my DCHP server working. I have a Mac G5 with Fedora 9 installed on it. It has two NICs, one is the onboard Apple NIC (eth1), the other is an Intel (eth0).

I'm trying to get it to where eth1 has outside access to the network and get's assigned an IP address by the outside network's DHCP server (which is working fine). I also want a DHCP server to run on eth0 to server the private subnet.

I've got DHCP installed just fine and I'm pretty sure I've got things configured correctly, but when I try and start the DHCP service it fails.

Here's the contents of the configuration files:

/etc/sysconfig/network-scripts/ifcfg-eth0:

# Intel Corporation 82541PI Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:1b:21:0c:d4:7e
ONBOOT=yes
DHCP_HOSTNAME=ps3-cluster-master
IPADDR=192.168.11.11
TYPE=Ethernet

/etc/dhcpd.conf:

ddns-update-style none;

default-lease-time 600;
max-lease-time 7200;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
authoritative;

# Use this to send dhcp log messages to a different log file (you also
# have to hack syslog.conf to complete the redirection).
log-facility local7;

option domain-name "cslabs.ewu.edu";
option domain-name-servers 146.187.134.22, 146.187.134.5;
option subnet-mask 255.255.254.0;

subnet 192.168.11.0 netmask 255.255.254.0 {
  range 192.168.11.1 192.168.11.8;
  option routers 192.168.11.1;
  option broadcast-address 192.168.11.255;
}

and
/etc/sysconfig/dhcpd

# Command line options here
DHCPDARGS=eth0

Just to note, in /etc/sysconfig/dhcpd, I've tried:

DHCPDARGS="eth0"

and

DHCPDARGS="eth0";

and I still get failure when starting the DHCP service. I've also tried including things like the gateway & netmask and all that stuff in the ifcfg-eth0 file as well.

If anyone has any suggestions, I'd appreciate it.

Thanks!

1
Contributor
1
Reply
4
Views
7 Years
Discussion Span
Last Post by bondo
0

OK, I got it figured out. I had a bad combination of my subnet number & the netmask. I wasn't aware that they had to match up. Just changed netmask from 255.255.254.0 to 255.255.255.0 and it works fine now.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.