0

This is my first post, apologies if I get anything wrong. Suspect this is something hard-to-fix :sad:

Set-up:
- Home LAN, DSL into a Linksys WAG54G DSL router
- 2 year old high spec PC as main server, wired connection
- 5 year old PC used by kids, wired connection
- 2 newish laptops, wireless connection
- all running XP Home with SP2

Symptom:
- problem is with the "main server PC"
- started getting intermittent dropped connection flashing in system try icon with message "a network cable is unplugged"
- intermittent problem got gradually worse over a period of 2 months
- became a permenant problem about a month ago

Steps taken so far:
- replaced cable with one that I know works, no difference
- tried each of the 4 wired points on the Linksys, no difference
- disabled the built in LAN card, rebooted, then re-enabled, no difference (well the network connection flashed a few times and I think I managed to download an e-mail, but then it disappeared since)
- went out and bought a new LAN card (Netgear GA311 10/100/1000 PCI card), disabled old one, installed new one, no difference
- hunted on Google and found DaniWeb, tried the solution listed here and tried changing settings from "Autodetect" to "Full Duplex 1000", no difference (also tried "Full Duplex 1000")

All the other PCs (the wired desktop and two wireless laptops) have continued as before, no problem, so I think the DSL/Router/Switch are ok. Thought it might be the PC (mfr went bust so my 5 year support contract is little use) but since new LAN card made no difference I'm suspicious about XP...

Any other ideas?

Mick

8
Contributors
8
Replies
9
Views
10 Years
Discussion Span
Last Post by jingda
0

Unless your router supports speed of 1000, the server's NIC wasn't going to work if set to full duplex. Is the old NIC still in the old server? take that out. Also, make sure your server is getting its ip by DHCP, don't assign a static ip to the server.

just do these things and get back here.

0

I had exactly the same problem as you and a very similar setup. I set my NIC speed down to Forced 10Mbit and it works no problem now.

I use the internet connection mostly, not internal network (no networked storage or anything fancy :) ) so I'll probably not notice the difference. Still, I would like to run 100Mb+ so I'm still wondering whether it's the router not being very cooperative with my NIC (i.e. negotiation is naff on the router), or whether my integrated NIC is on its way out (cos I have a passive cooler on my NForce chip).

I'll try 100Mb non-duplex and see if that improves the connection stability. It used to work fine at 100Mb before (the balloon reported 100Mbit) but it doesnt indicate whether it was Duplex or not...

Robimus
-Daniweb nOOb. :)

0

Oops! I just re-read. You're trying 1000Kbit but I am having trouble with 100Kbit, so not exactly the same after all!

0

I am encountering the same intermittent "disconnect" with the "A Cable Connection is Unplugged" message... Recently I replaced a 4-port DLink 604 (non-wireless) router with a Netgear Ruckus "wireless" 4 port router. Worked fine for several weeks, and now "BANGO!" Affects my other LAN computer on the home network as well.. Any latebreaking suggestions? Thanks.

0

Hi,

Try pinging 127.0.0.1 if you are able to ping then your lancard is working fine or else check the RJ45 jack colour sequence as it is 2 dissimilar devices the cabling should be Straight cabling mostly the cabling sequence might be wrong it should be straight cabling and not crossover cabling.Cabling makes alot of difference in connectivity problem.

0

I doubt this will work, but maybe an update to SP3 might fix things. If it was a degenerative problem it's likely to be a software issue.

0

Guys!!!! This thread dated back to 2006, last post is last year in 2010. Why are you guys replying to a dead thread more than 3 months old.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.