0

Hi, I've been searching the forum as well as the net for a solution to this problem, but can't find anything that's exactly like my situation, although it seems like a very common scenario.

I have a Scientific Atlanta cable modem with 1 Ethernet port through which I used to temporarily host a site via Apache as well as hosting online games. Recently I bought a TPLink wireless router which I connected to the cable modem and are using it to access the internet. The problem is that I can no longer host anything; ie. no other computer on the net can connect to mine.

I assume that the cable modem doesn't have an IP address range since it only has one port and since everything works fine when I connect directly through it, so what I did was a reserved an IP in my wireless router for my computer as well as disabling DHCP. I'm sure I'm missing another step, so if somebody can help me out here I'd be much obliged...

2
Contributors
14
Replies
16
Views
6 Years
Discussion Span
Last Post by jingda
0

Try enabling DHCP. Are you connecting using an ethernet cable or wireless? Check your firewall too.

Edited by jingda: n/a

0

Re-activated DHCP -- no luck. The reason why I disabled it in the first place was because it wasn't working and I read in a couple of threads that it should be disabled. Also tried disabling Windows Firewall, no luck either.

I connect via ethernet cable to one of the 4 ports on the wireless router. The wireless router connects to the cable modem's 1 and only ethernet port via ethernet cable from its WAN port. Going online works fine, and other computers can access the internet through my router normally, the only problem is hosting.

My external IP is currently 198.169.56.20. My internal IP is fixed on 192.168.1.99 while the DHCP range on the router is from 192.168.1.100/199. The gateway (the wireless router itself) is 192.168.1.1

What to do?

0

Is your router configure properly to host games. Have you port forwaded the Public IP address to your Local IP address?

0

I tried assigning port 80 to my private IP 192.168.1.99, while my private IP is assigned to my MAC address... no luck.

Any ideas?

0

Ok I followed the link to the portforward.com website and followed their instructions. First I downloaded their program and changed my IP from dynamic to static. Pretty easy. After that I forwarded the ports 80 and 443, which Apache uses, to my new static IP through the "virtual servers" option on my router. Also pretty easy. On the site it says it should work, but when I try a port test, the ports are reportedly closed???

I don't get it, what am I doing wrong or what else am I missing?

0

Can show me the link you get the instructions from. I don't know what is your router model.

0

Alright, the port is OPEN when Apache isn't running, but when it's running it's closed. Is this normal?

The problem is that it still doesn't host for some reason.

But as soon as I plug my computer directly to the cable modem, it hosts without a problem.

Any ideas?

0

When you plug in to your cablemodem and follow the instructions in the link it work perfectly fine, right? If that is the case, it is some router settings causing the issue, you have to figure it out yourself because i am using a linksys router and not a tplink. So i can't help you with that, sorry. Maybe you would like to fine someone who use the same router as you and is able to host online games with apache. Maybe that persob know how to do it. Good luck:)

0

Actually when i plug in to the modem, I don't need to follow the instructions because I don't need to forward any ports. This just means that I don't have a software problem, I'm sure it's like you said, I need to do something with the router. I found this screenshot on the net of what the menu looks like, can that help?
http://obrazki.elektroda.net/59_1260128769.jpg

0

Nope. Unless i use a TP link router, you have to ask someone who has host online games before and is using a tplink router. Your friends or neightbours,perhaps.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.