0

Hi,

I'm have a strange problem that I think's being caused by my router. I have several sites running on my local machine (WinXP Pro) and I use the Hosts files to direct for eg site1.local to 127.0.0.1 (Apache) and site2.local to 127.0.0.2 (IIS). Everything works fine when I'm not connected to the net, or when I'm on dialup but if I'm connected to my D-Link G604T router (even if the router isn't connected to the internet) my local sites run really slow - taking 20-30 seconds to load a blank page, for example. It also happens if I just go to http://localhost, but if I type in the IP address (like 127.0.0.1 or 127.0.0.2) it works fine.
Is there some kind of setting somewhere that is trying slowing down the host names but not the IP addresses?

Thanks,
Nathan

3
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by DimaYasny
0

Doh. I had a response and then hit the wrong button.

The question is whether the issue is on the client side (web browser) or server side (web server). The symptoms suggest client, however, since it behaves "normal" when not connected.

A few things to try from a command prompt:

c:\>ipconfig /all

This will display the DNS' server list and order. Perhaps it is getting a tad confused somewhere.

c:\>route print

Make sure your 127.0.0.x's are all there nice and pretty.

Sounds like a name lookup issue, hope the above sheds some light on the problem.

0

Thanks for the response. None of this makes sense to me...does it mean anything to you?

C:\Documents and Settings\Nathan Cox>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : flyingmonkey
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Cont
roller
Physical Address. . . . . . . . . : 00-15-C5-04-A0-A7

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
k Connection
Physical Address. . . . . . . . . : 00-13-02-2E-D2-5A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.1.1.2
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Default Gateway . . . . . . . . . : 10.1.1.1
DHCP Server . . . . . . . . . . . : 10.1.1.1
DNS Servers . . . . . . . . . . . : 10.1.1.1
Lease Obtained. . . . . . . . . . : Tuesday, 8 May 2007 5:39:17 p.m.
Lease Expires . . . . . . . . . . : Tuesday, 8 May 2007 6:39:17 p.m.

C:\Documents and Settings\Nathan Cox>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 15 c5 04 a0 a7 ...... Broadcom 440x 10/100 Integrated Controller
0x50004 ...00 13 02 2e d2 5a ...... Intel(R) PRO/Wireless 3945ABG Network Connec
tion
===========================================================================
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 10.1.1.1 10.1.1.2 25
10.0.0.0 255.0.0.0 10.1.1.2 10.1.1.2 25
10.1.1.2 255.255.255.255 127.0.0.1 127.0.0.1 25
10.255.255.255 255.255.255.255 10.1.1.2 10.1.1.2 25
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
224.0.0.0 240.0.0.0 10.1.1.2 10.1.1.2 25
255.255.255.255 255.255.255.255 10.1.1.2 10.1.1.2 1
255.255.255.255 255.255.255.255 10.1.1.2 10003 1
Default Gateway: 10.1.1.1
===========================================================================
Persistent Routes:
None

0

the router has nothing to do with it. but your configuration is still a bit of a mess, that is theoretically right, but windows keeps screwing it up.

Why not run apache on a VM under linux, as it should be run, and while you're at it, set up bind or djb on the same VM?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.