hi. on trying to do dusting on my desk top,i removed the cmos battery and kept it through out the whole night. after re-installing the cmos , tried to reboot and instead i got a message asking me to insert a system disk and press enter i did that but in the process of booting, a message resading 'mass storage device not found" with the computer explaining that that it could be inproper connection of hard drive. but all connections were rightly done. even when i tried repairing the operating system i could still get the same message. please some one with a solution should help thanks in advance

When you power on the computer, hit the key that is displayed to get you into the BIOS/CMOS setup.

Go through the screens and make sure that your hard drive is set to auto detect. By removing the battery, you reset the configuration. If the config is not set properly, your hard drive may not be located by the BIOS.

Several things happen when you remove the CMOS battery for more than a very short period of time (like to replace it with a new battery), and the system is unpowered.

  1. The CMOS memory is erased. This is where the BIOS settings are stored.
  2. The system is restored to factory defaults - pre-system installation.
  3. In some cases, the EPROM/flash data may be erased (should not happen in current systems).

So, you will have to go into the BIOS and re-configure ALL of the system settings. Then, you may be able to reboot after saving the settings (CPU configuration, date+time, boot order, etc).

This article has been dead for over six months. Start a new discussion instead.