I just bought a Figo Nitro 4X cell phone (Android 8.1) phone for my son. When I connect my cell phone (Figo Android 6) to my Windows 10 laptop it displays in file manager with an icon that I can open to see all the folders on my phone. From there I can easily copy files back and forth with file manager.

When I plug in the new phone I still get the icon but when I open it I get a blank screen. No folders. The USB settings I have available on the phone are:

  1. Charge Only
  2. Media Device (MTP)
  3. Camera (PTP)
  4. USB virtual drive

The first three options get me a blank window. The last option shows the phone as a CD-ROM and opening it shows a readme file. The "drive" is read only.

Any suggestions? Online help is pretty much useless as they refer to USB options that are no longer valid in Android 8.

Recommended Answers

I hear you. This other discussion parrots all the things I've done over time.

To quote Roseanne Roseannadanna, "It's always something. If it's not one thing it's another."

The one about "Revoke USB …

Jump to Post

All 2 Replies

I hear you. This other discussion parrots all the things I've done over time.

To quote Roseanne Roseannadanna, "It's always something. If it's not one thing it's another."

The one about "Revoke USB debugging authorisations" is one I recall since I do, once in a while use the USB debugging with Android Studio.

commented: You did it again. +15

One of the suggestions worked. Much appreciated.

commented: Thanks for that. I wish it was always the same thing but it rarely is. +15
Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.