0

One day my DVD/RW just quite working; but hey, now I've got a real cool cup holder. It will open and close, all wires are secure (I removed and replaced). I'm sure it has something to do with the driver. The PC doesn't recognize the D: drive. The media I got with the PC didn't have a driver for DVD/RW, but I downloaded the driver from the internet, but no good. So I figured the the DVD/RW was dead (3 yrs old). Bought a new one (OEM) ... yeah, same story... the new DVD/RW didn't come with a driver and I can't find one online. Windows XP didn't recognize the new hardware and automatically install the driver.

I went into "add hardware" the DVD/RW is listed there; it's got a big fat yellow circle with an exclamation mark in the center of it. I double click and get the following message.
"Windows cannot load the device drive for this hardware. The drive may be corrupted or missing. (Code 39)." Which by the way, was the same message I got with old DVD/RW.

I was told I may have to re-format my hard drive but I'm really hoping there's another solution for the issue cuz i don't like that one.

I'd appreciate any suggestions or ideas.

Thanks

4
Contributors
5
Replies
6
Views
9 Years
Discussion Span
Last Post by caperjack
0

The driver for your Optical drive is usually a generic driver supplied with Windows.

Check if you can see the drive in the P.O.S.T.

It may show there and not in Windows, then you have to repair your windows installation.

Else double check that all jumper settings are okay, or change the cables, try a new one maybe?

>BstrucT

0

I would recommend swapping cables and see if that works as suggested. Maybe just maybe the device has been disbaled from the device manager but i think that would have been ruled out by changin to new drive. I d say faulty cables. Give it a shot and see what happens

Raj

0

Give this a try i think its your problem.
--------------------------------
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Reasons for this error include a driver that is not present; a binary file that is corrupt; a file I/O problem, or a driver that references an entry point in another binary file that could not be loaded.

Have you installed a 'packet driver' lately??

Possible Solution...... go to Start /run/ type in ,regedit.and do the following

There are 2 reg keys that can screw the device......remove them both and reboot......

The keys are:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325 -11CE-BFC1-08002BE10318} - "Upperfilters" and "Lowerfilters".

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.