0

I have a WD 160 GB 7200 rpm hd on primary IDE channel set as master, its the only thing on that channel. an optical disk is on secondary ide channel.

looking in device manager, under ide ata/atpi controllers under primary ide channel advanced properties the transfer mode for both devices is set to 'DMA if available' but the primary HD is using ultra dma mode 2 as the 'current transfer mode'.

I have reinstalled win xp a bunch of times now, set jumpers on that hard drive to master, cs, slave etc and it simply won't run at its proper faster dma mode 5 ata100/133 speed.

looking in event viewer I get the following error which on the MS web site says it most likely related to a cable problem even though the actual error message says 'controller error'. It's a fairly new cable, but i believe in the past ive tried a few different ata100/133 cables on that same hard drive with no better results.

Event Type: Error
Event Source: Disk
Event Category: None
Event ID: 11
Date: 3/12/2005
Time: 3:03:34 PM
User: N/A
Computer:
Description:
The driver detected a controller error on \Device\Harddisk2\D.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

what the hell is going on, why can't i get this hd to use a faster IO mode? Thanks

3
Contributors
5
Replies
6
Views
12 Years
Discussion Span
Last Post by Thong_Ispector
0

Well, this might be a silly thing to ask, but what motherboard do you have there?

Is ATA133 properly set up in the BIOS (usually as "Auto"?)?

Are you sure you're using an 80 wire cable?

Have you installed the latest motherboard chipset drivers?

0

Well, this might be a silly thing to ask, but what motherboard do you have there?

Is ATA133 properly set up in the BIOS (usually as "Auto"?)?

Are you sure you're using an 80 wire cable?

Have you installed the latest motherboard chipset drivers?

asus a7n8x-x, yes its set for auto, yes 80 wire cable, yes latest mobo chipset drivers.

0

Does the hard drive run at full speed in any other PCs?

hmmm not sure, i only have 1 desktop. but i also just deleted my ide channel and thought maybe windowns would pick up true speed on reboot... it didn't.

on the bootup after the POST, when it detects ide devices, it comes up as ata33. in the bios it has the correct hd listed so im not sure why it won't run at full speed. I know for sure its a ata100/133 hd.

0

Try resetting the cmos to failsafe just to see if it changes anything...
There might be a setting or tweak that you just are not seeing in the config.
You seem to have covered everything else

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.