Hi people, I need experts to answer this one as I have tried just about everything to resolve this problem, maybe someone can help. I'll explain what I have done to date.
I built this computer a year ago using online info which I later found was erroneous.
I have since experienced lockup problems that would occur at random, anywhere between the POST and after windows startup completion. I would sometimes run the computer all day without a lockup.
I have changed the mainboard, all 4gigs of ram, PSU from 650w to 1000w thinking I had a power problem, no change, reseated the cpu, have a huge fan and cooler installed with good heat extraction system, updated all the hardware drivers, latest MB chipset and bios, removed my SB X-Fi thinking that might have been a problem, no change. Had a problem where the computer would lockup while I was browsing the bios, only a few cursor movements would cause a lockup. I tried flashing the bios with older ones and found one to work that would at least allow me to browse the bios screen which is a vista update.
Everytime I start up the computer and at random, recieve a bios error "The system has detected unsuccessful boot attempts" and requires a bios reset. I have tried selecting bios defaults and saving, no change. I notice that the bios finds my ram to be of 1333mhz, timing 9-9-9-24 which is correct but displays the voltage as 1.54 which is incorrect as the Micron ram requires a 1.50 v setting. I recieve different reading from the bios with the different bios flashing I have ran, including the win7 bios update which just does not work properly due to recieving incorrect ram voltages among other variables.
I am starting to think that the bios chip is faulty and might be the problem. Either that, or Intel have yet to write a bios update that works.
Any takes on all this?. I really would appreciate some expert help, thanks people.

Configuaration:

Intel Extreme DX48BT2 mainboard socket LGA775
4gigs - Micron MT16JTF25664AY-1G4BYES 2 GB 1333 9-9-9 Non-ECC
Corsair 1000w PSU
Intel Core2 extreme X9770 @ 3.2ghz
Sounblaster X-FI sound card
Nvidia geforce 9800 gtx+
NZXT atx case.

I don't have a solution for you but a suggestion, try changing your processor if you can find a friend who has a LGA775 socket processor. Since you have change your MB, memory sticks and the Power supply.

Thank you for your response. Unfortunately, I dont know anyone that has socket 775.
I purchased the cpu online from some guy for $500 when at the time it was going for around $3500 new. Maybe it does have problems. Whats strange is that it will sometimes go the entire day without a hitch. If there was indeed something wrong with it, wouldnt it be problematic consistently?.

No assistence. Closing thread.