0

When ever I eject a DVD from my ROM drive ( DVD burner drive ) my Computer keeps telling me that there is no disk in the drive. ( DVD Burner )
It doesn't matter how many times I click on cancel or the Red X I cannot get this message to go away.
I am running Windows XP SP3.
This problem has been happening for awhile now.
Any help on how to fix it please?

3
Contributors
12
Replies
14
Views
6 Years
Discussion Span
Last Post by demo61
0

I have updated all the drivers for both my DVD & CD Rom drives and the same message still comes up, at first I thought it was being caused by my Corell Photo Monitor but even after uninstalling that program I still get the same message.
I know it shouldn't happen, it just annoys me that I have to click Minimize to place it on the Task Bar.

0

maybe the DVD you're trying to eject may still in use...
it's commonly occur when you run something from disk drive and eject it without closing the program...

Check again which program affiliate with your burner... Maybe anti-virus had done a scan on your burner in background...

0

It doesn't matter even if I put a Blank Disk in either drive. When I eject it I still get the message there is no disk in drive ( D - E )
It looks as though I will just have to put up with it .

0

anti-virus might have done something here. check your av setting.

also try this for windows error/problem
* open command prompt
* type in 'chkdsk' and press enter (it should be quick)

tell us the results when it's done...

0

Did all that and found no errors.
Doesn't that just check my hard drive ( C ) it is my DVD & CD Rom drives that I am having trouble with.

0

I think I have just fixed my problem.
Did as you said and run "chkdsk" but found no errors.
I then went into Computer Management and then Disk Management, from there I selected each DVD & Cd Rom drives and on driver details clicked on driver update.
I got back the message saying no new updates were available, keep the drivers I had already.
Closed everything down and rebooted computer. I then stuck a DVD in Drive D ( my DVD Rom )(PC User Disk.) Opened it up , looked around to make sure my computer knew I was looking at different items on the Disk.
Closed Drive down and removed Disk, Wallah, No messages any more.
Tried this a couple of times and every thing works fine.
Thanks to all that gave me info on how to rectify this problem.
Hopefully this might help any one else who has this problem.

0

Good to see that your problem is solved on your own and sorry we couldn't provide instant solution for your problem...

Cheers...

0

Done, told you updating the drivers would solve that.;)

Good to hear your problem is solved:)

Edited by jingda: n/a

0

I had previously updated my drivers before and it made no difference.
This time I went onto Disk management area and selected each drive and updated drivers that way.
Why it didn't work before I don't know but every thing is going OK now.
Thanks for all the help.
Hope this thread helps others solve their problems as well.

0

You can check whether your drive is up to date or not properly install by going to the device manager and have a look. Some drivers require you to manual update it by going to device manager and update it. But still glad your problem is solved:)

Do come back to daniweb if you have any problems. See ya then;)

0

That's exactly what I did, went onto Device Manager and updated the drivers from there and every thing works fine now.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.