I can't see my I:\ drive in My pc.
That's an external usb drive, and works ok. I can access it ok,
and disc works fine but it just won't show on My pc.

I don't want to change drive letter (can't explain reasons but simply can't).
I need it to be I:\
Shows ok on disck managment.

The problem started after trying a ?!!#** freeware, that "hided" the disc, (unfortunatelly, silly me,
was no technical support nor way to "unhide" it again. don't remember software name.

The thing is the drive is there, it just don't appear at all on My pc as an icon.

Tried deleting "NoDrives" regedit key (or setting it al to zero with no results).

Help!

The settings in this key, HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer override the setting in this key: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
So set the value NoDrives in the former key to 0 [zero].