Hi ppl.

I have been struggling with this one for couple of days now.
It appears that my Windows XP think that my Pioneer DVR 110 D is a CD-ROM drive. I've learned how to make windows think it is a burner, but I can't make it recognize it as DVD/RW drive. I had daemon tools installed + alcohol 120% + powerISO. I've uninstalled daemon tools and disabled all the virtual drives to no avail. It's still a CD-ROM. Some functions are gone (like auto-play DVD movies). When I check the volume properties and click "populate" button (while DVD movie inserted) all the values are the same as if the drive is empty.
The drive reads and burns like before, but with the windows thinking it's a CD-ROM, some of the perks of a DVD/RW are gone.

I've tried uninstalling the driver via device manager, reinstalling the chipset drivers, manually installing the CD driver... next step will be flushing the device info from the registry, but I'm hesitating...

Reinstalling windows is out of the question. It is up-to-date now and reinstalling it would mean downloading all of the updates again via modem. No way.

For the record:

Nero works with it like it worked before it became CD-ROM.

I can't play DVD movies in media player 10. Says "Windows Media Player cannot play the DVD because a problem occurred with digital copyright protection."

PowerDVD says "Copy protection cannot be enabled. Please make sure any other copy protected content is not being shown now."

Intervideo WinDVD plays the movies.

There is no "DVD movies" listed in the "Autoplay" tab.

Recommended Answers

All 3 Replies

Have you tried checking the drive on a nother computer? It's possible that some parts of the DVD (specifically the part retaining to copy protection) may have gone bad. If this is the case, the only recourse would be to get the drive serviced or getting a new drive

Drive works in a hardware way. It reads DVD-R and RW's and burns them in Nero.
When I go in device manager and look at the properities of the drive, there is a "Volumes" tab. When I click "populate" this is what I get:

Disk: CD-ROM 3
Type: DVD
Status: No Media
Partition style: Not Applicable
Capacity: 0 MB
Unallocated space: 0 MB
Reserved space: 0 MB

+ the volumes table is empty allthough there is DVD-RW inserted.

I have CD-ROM alongside, and the same thing is happening with it. Can't be both at same time going crazy.

There's no driver that came with it, so the windows are equipped with the generic one that should cover all the basis.

It is most probably that my NAV screwed things up here (read my latest thread). I'm now in a proccess of reading the threads ppl wrote regarding this problem with nForce4 chipset.

Other possibility is conflicting low and high filters (redbook and imapi in my case - used to be more, but I've deleted the registy values). I must say that the filters are not my brightest side.
I did try Forcesapi v1.7 to no avail.

I must add that I've found in registry (HKLM/system/currentcontrollset/services) there are couple of INITSTARTFAILED dwords with a value "1":

- CDAudio (related to redbook)
- kbdhid (keyboard HID driver, all OK in device manager(?))
- Processor (one clling the "processr.sys". In device manager "Processor" is run by "AMDK8.sys" )
- Sfloppy (again, all OK in device manager)

I gave up and reinstalled the OS.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.