0

hey i have a bit of a problem, my laptop acer 290, wont boot it starts up fan spins and then dies, ive tried re setting the ram and ive tried booting with a boot disk and it still wont boot, any ideas guys?:sad:

15
Contributors
21
Replies
22
Views
10 Years
Discussion Span
Last Post by jingda
0

Have you tried blowing it out, there isn'y a lot of space in laptops for circulation so getting dust and other fiberous material in there can cause a loss of circulation which in turn can causes over heating which will shut the machine down.

0

hey i have a bit of a problem, my laptop acer 290, wont boot it starts up fan spins and then dies, ive tried re setting the ram and ive tried booting with a boot disk and it still wont boot, any ideas guys?:sad:

G'day, I am having a similar problem with an Acer Travelmate 530. Have you managed to solve the problem. If so how? Regards, Salman Shami

0

have you had any luck my 290 went dead as well 2 days ago. The power comes on but no screen, fan spins and thats about it. Can turn power off as well. Please help.

0

Can you hear the post beep when the laptop is switched on ? If not I would be tempted to replace the battery on the motherboard and trying to hear the post beep

0

no i cant hear the post beep when i try to start up, i havent had a look for the battery, i cant remember for the life of me where it would be

0

Hi all, I have this exact same problem... Acer 290 trys to start, 2 LED lights come on (the 1st 2) then just dies out after the fan spins for 2 or 3 seconds.

This had actually happened to me a 3 or so times before and I had found a way of pressing slightly inbetween the 2nd last and last LED light that would "spike" something and make the computer wakeup and work just fine. Until the day I tried and tried but it didn't work properly (something must have gotten loose?) and would randomly lockup and reboot itself or go into that "dead mode" ever since then its stayed as is.

Mine didn't happen as abrupt as others because I knew what I had to do to make it work (press slightly inbetween the 2nd last and last LED lights and hey presto!) But when it locked up on me that first time I knew I was in for a right poo storm. Giving the lappy to my IT techy at work and I'll see how he goes with it.

I know there is also a service manual out there for download with full instructions how to pull apart. Just google : Acer Travelmate 290 Service manual. But I do warm you I got as far as taking the back cover off before I backed out... there's SO many screws and little bits if you got big tools and bigger fingers your in for a hard time.

0

Final verdict was the MOTHERBOARD was fried... kaput... fin. The only options now are to either buy a new motherboard for approx $500 AUS, or throw away the old and in with the new. Im lucky cause its a work computer I can claim it :) Hope that solves some peoples problems as I was doing my head in over this one.

0

Don't blame the motherboard. I have found in almost every case I had, that the processor was unseated in the socket. They sometimes have a tendency to move a bit and some of the pins don't quite make it in the socket. You should buy that service manual. It might be a good investment. good Luck

Dstand

0

I have this model currently on my workbench. The machine starts, the fan blows and all lights come on. The screen can get to the BIOS after pressing F2 but then goes orange a line appears then goes white and stays white. I tried attaching an external monitor but nothing happens. I have been told this is a graphic card problem and that the graphic card will need to be replaced. As this card is built on to the mother board there is no way for an amateur to get this off and replaced. I am currently searching for a new mainboard.
I have the manual for this particular machine, if anyone needs it drop by my website www.zeklink.com and mail me for a copy.

0

Hi friends,
I got a problem with my acer travelmate 2030 laptop. Since my charging adapter is working fine. its not charging.
Is it related to motherboard power IC problem? if could be posiible, how much is IC cost(INR)?

0

Hi friends,
I got a problem with my acer travelmate 2030 laptop. Since my charging adapter is working fine. its not charging.
Is it related to motherboard power IC problem? if could be posiible, how much is IC cost(INR)?

Try starting your own thread with your problem instead of adding it to another member's thread.
Nobody here can categorically tell you what the problem may be. Take it to a shop so it can be diagnosed.

0

hi: i have just picked up a 290, maybe from one of you, for $16 same prob.. for you that dont know acer doesnt make this unit it is made by COMPAL and the motherbrd and whole chassis is a compal CL51. case decorated for acer and bios was altered for acer. i have a TDN NX5300 compal cl51-15, all identical. both compal and clevo build costem laptops for everyone else. i havent checked yet to see if this mthrbrd has a maxim cpu voltage regulater chip. some hp's do,nc6000, and some guys found the tiny solder connection are fracturing on it which causes all sorts of weird prob's. if you can find a good cl51 compal brd i'd use it in place of. if i figure olt the prob on mine i'll post here [email]<snip>[/email]

Edited by crunchie: snipped email address.

0

zeklink i saw some things on the hp models that wre have vid probs. the vid graphic chip and mther brd get too hot . the chip over heats and unsolders some of terminals. there were guys out there that were fixing them by shielding all parts but vid chip then using a very hot heat gun to remelt the whole thing. theres a video by a guy that shows how he did it and how to do that . if your going to discard od scrap/part out this unit it might be worth tring that first. mz

0

''Hi all, I have this exact same problem... Acer 290 trys to start, 2 LED lights come on (the 1st 2) then just dies out after the fan spins for 2 or 3 seconds''.......

A MILLION OF THANKS TO YOU!! IT JUST WORKED TO ME NOW!. HUH HUH!

FOR A MONTH I HAVE BEEN SUFFERING FROM THE PROBLEM OF THIS LAPTOP ACER-TRAVELMATE 290.
IT FAILS TO BOOT. IT SHOWS POST FOR A JUST ONE SECONDS THEN OF IT GOES OFF. IN ABOUT 15 TRIALS TO POWER IT ON YOU CAN SUCCEED ONLY 1 OR ZERO.

SOON AS YOU PRESS THE POWER BUTTON THE TWO GREEN LEDs ARE ON BUT ONCE THE TWO GREEN LEDS(on the upper side above the keyboard) ARE LIGHTING ON BUT IT TAKES ONLY 2 0R 3 SECONDS THEY ARE ALL GOING OFF. THE HARD DISK IS OFF.

I THOUGHT IT IS THE FAULTY IN THE OPERATING SYSTEM SO I REFORMATTED IT AND INSTALLED IT WITH WINDOWS XP. WHEN THE SETUP/RE INSTALLATION COMPLETE ...THE PROBLEM PERSISTED.

I REFORMATTED THE HARD DISK AND REINSTALLED WITH WINDOWS 98 JUST TO TRY..BUT PROBLEM PERSISTED.
I RETURNED AGAIN THE WINDOWS XP.. BUT AGAIN PROBLEM PERSISTED.THE PROCESS TO FORMAT AND REINSTALLING THE OS WAS VERY VERY TEDIOUS AND DISCOURAGING AS SOME TIMES THE LAPTOP WENT OFF IN THE MIDDLE OF FORMATTING OR SETUP HENCE FORCED ME TO REPEAT IT FROM BEGINNING SEVERAL TIME(IT TOOK ME 2 WEEKS).. WHEN THE SETUP COMPLETED PROBLEM PERSISTED.. here i concluded that it is nothing having to do with the OS.
I OPENED THE CASE/COVERS UP TO THE MOTHERBOARD. I DIS-ASSEMBLED IT ALMOST EVERY PART /PIECE TO ITS PLACE LEAVING ALMOST A MERE MOTHERBOARD AND I USED A BLOWER TO BLOW EVERY PARTICLE OF DUST FROM THOSE INNER COMPONENTS.THEN I RE-ASSEMBLED/RETURNED EVERY THING TO ITS PLACE AND COVERED ALL THE CASES CORRECTLY AS BEFORE. WHEN I POWERED IT ON ...GHRRRR! THE PROBLEM PERSISTED. UH!!

TODAY I TRIED EVEN TO CHANGE THE TWO RAM CHIPS (suspecting anything wrong with memory). IT HAS TWO EACH OF WHICH WITH 512MB SO TOTALLY MAKING ABOUT 1GB. BUT EVEN AFTER REPLACING IT WITH OTHER RAM CHIPS... THE PROBLEM PERSISTED..

UNTIL I CONSULTED WITH OTHER GUYS IN THIS HELP SITE.. I FOUND THE ADVICE/HINT (see the part quoted on the very top of my mail).. THEN AFTER PRESSING AT THAT SAID AREA OF LEDs THE LAPTOP SURPRISINGLY BOOTED SEVERAL TIME WITHOUT PROBLEM.
SO I WENT EVEN FURTHER STEP. I REMOVED THE TFT SCREEN A BIT TO BE ABLE TO REMOVE THE UPPER FLIP (about 1.5 by 13 inches). THEN REMOVED THE KEYBOARD(very easy..its only two screws) THEN THE TWO SMALL FLIPS FROM HERE I HAD ACCESS TO THE PROCESSOR SCREWS
.. I TIGHTENED THE TWO SCREWS AT THE PROCESSOR WHICH CORRESPONDS TO THE AREA OF THOSE TWO LEDs ABOVE WHERE I WAS PRESSING BEFORE...
FROM HERE I RETURNED THE 2 SMALL FLIPS AND THE KEYBOARD AND POWERED THE LAPTOP ..WOOOH! IT NOW WORKS.

I POWERED IT OFF AND ON AGAIN SEVERAL TIME OFF AND ON AGAIN SEVERAL TIME IT WORKS ALL 10 EVENTS.
(if you fail here i guess you can succeed by removing the one screw which is holding the small card which carry six LEDs)THEN HOPEFUL IT WILL WORK.

I HAVE TRIED TO ON/FF IT SEVERAL TIME 20 TIMES. IT WORKED ALL!! THANK YOU!! BE BLESSED!!.
Pascal Mwalyenga NGARA-KAGERA-TANZANIA. <snip>

Edited by crunchie: snipped email address.

0

Start a new thread and post your problems. People are not willing to help in a old thread and do not use block letter next time. It irrtates me. Sorry but no offense. Its crap also since it works why do you still bother to post and tell us, Spam

Edited by jingda: n/a

0

Hi mwalyenga and welcome to Daniweb :).

As jingda has said, please start your own thread and try not to use CAPITAL letters, as on the net it means you are SHOUTING :).

0

for what it worth ,in my opinion the poster has no problem ,the caps part of the story is likely a copy past from some website ,the email address was added in the hope that one of us email them and they would then have out email address and start spamming our email ,there are a lot ,and i mean a lot ,of these type post now on daniweb forum now [and it needs to stop or people will stop helping or coming here for help ],so many it beginning to ruin this forum in my opinion

0

my travelmate 290 CL51, it boots up but unable to detect the hdd and the cdrom, can anybody encounter this problem, share please....

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.