0

For the longest time, I have wanted to duel-boot both Windows 98 SE, and Windows XP home on the same computer. With my new computer, I have finally done just that. I plan on installing other operating systems at a later date.

My problem has nothing to do with duel-booting, but with Windows 98 itself. I am using an Asus p4p800 e deluxe motherboard. I am using onboard ethernet, and I'm on a network with a bunch of computers sharing a Dell router. When I put in the CD, and select to install the "Yukon" drivers (which I think is the right thing for the onboard ethernet), the setup begins.

After the setup is completed (which takes only a few seconds, but that could be because my new computer is very fast), I am told the computer will restart. When windows starts up again, it does not start any programs, not even explorer, and instead says something around the lines of "Please wait while Windows builds its driver information database". It then starts detecting devices and installing the software for them.

This is where the problem occures. Only one of the roughly five devices installs. The other devices instead bring up a screen that gives me the option of either searching for the driver, or manually getting it. The manual screen is too complex for me (it askes me what type of device it is when I have no idea), so I have it search. It asks me where I want to search, and I select different things (I have tried every combination you can think of), and then I hit next.

It then tells me that it was unable to find the driver for the device. It says to choose not to install the driver, I should hit next, otherwise I should hit back to try again. I have tried many times, and always I inevitably give up and click next.

When I first did this, I thought things were working anyway, because my Norton stopped giving me a funny error it gives when you have no internet. The Norton alert tracker on the side started saying stuff like "access rules automatically created for x".

I was then told to restart my computer. When I started it again, I could not start Internet Explorer (I just got a screen for MSN internet access. The strange part is that I am able to run Norton's LiveUpdate without a problem, so there must be a connection of some kind.

Here's what I've tried:

Seeing if XP has internet - it does, without any need to install the yukon drivers in the first place. I just ran the Network Setup Wizard.

Creating a Network Setup Wizard Floppy using XP, and running it on 98 - The Wizard installs the files, has me restart, and, upon startup, gives me an error saying that it can't detect the right devices to setup the network.

On the driver search screen specifing a location on the driver CD to try and get the right drivers - I don't think this helps, because I've tried selecting everything that could possibly be the right folder, and it still doesn't detect anything.

While my brother, who is rather inexperienced, built this computer, I find it unlikely this is a hardware problem, because Windows XP detects things properly.

Operating Systems:

First Physical Hard Drive, 80gb, Microsoft Windows 98 Second Edition (no updates because I can't open IE)

Second Physical Hard Drive, 80gb, Microsoft Windows XP Home Edition Service Pack 2

Is this fixable? If not, is there a way I can completely close off my internet connection? Since I can't get Windows Updates, I'm worried about getting hacked, so if there's no way to completely get internet, then I'll want to close it off completly, and just use XP for my internet.

3
Contributors
5
Replies
6
Views
12 Years
Discussion Span
Last Post by Kamex
0

The possibility of getting hacked is extremely unlikely. This does sound like a driver problem, although I'm not sure why you want to run off 98 and xp, when xp will do the job sufficiently anyway.

Anyhows, the best thing to do is go to device management and see if there is a driver conflict as such, or if the device is being recognised, but installation of the driver is incompatible with 98, either way wanting to have 98 is causing more hassle than its worth.

If all fails you may want to try getting a proper network card, rather than your mothereboards built in one, I recall having trouble with my built in card on an installation of 2000.

Good luck

0

First of all don't be discouraged by people that ask why you would run 98se and XP...

98se does everything I need and the only reason I run XP is to become familiar with it... And it dosen't report back to M$ every time I change my hardware...
It lets me swap HD between machines and alot more...

It was definately the wrong driver and we need to identify the correct one to get you straightened out.

If you have another plug-in network card handy we can use that...

I'll check back after morning coffee...

0

Here are the latest 98se drivers from Marvell for your network card...
(Under 100k) Unzip them to a location you wont forget....

Delete the existing drivers and look in device manager to see what if anything else didn't install because of the wrong drivers...

Oh, and verify that CMOS has the onboard network card active...
I know it is, but it is just a force of habit...

We can start with that and move on...

0

Thank you so much for taking the time to find those drivers for me. Unfortunatly, installing them did not seem to change the situation. Liveupdate is still fully functional, and IE continues to say that I have no internet connection, asking me to get MSN.

In addition, I tried installing Firefox by booting to XP (since XP's connection has been fine all along), downloading the file to the c drive, and running it in 98. Just like IE, My Firefox is not able to connect to the internet on 98.

This is really puzzling me.

Edit: Apparently, I thought I had upgraded but I hadn't. Now that I've upgraded. Firefox is able to connect to the internet. However, IE is not able to, and continues to bring up the MSN screen instead of starting up, so it looks like it's just IE at this point, any suggestions for getting IE to work? I feel like I'm close. Can anyone fix this last problem?

0

The problem has been solved. Updating the drivers fixed the internet, but IE still was not working. To fix IE, I right-clicked on the IE icon on the desktop and clicked properties. I then went to the Internet Connection Setup Wizard and went through it. My problem with IE was solved. I am now happily downloading the updates (posting with my Mom's computer). Thank you for helping me, I really appreciate it. :D

Someone should mark this as solved. :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.