I had a PII running XP home on a 80G seagate hard drive. I bought a bare bones system w/ AMD Athlon XP 2700+ processor and 512M of ram. The manufaceur has the XP certificate for this mother board. I used the video card and hard drive out of the old systems, I formatted the hard drive and reinstalled XP. I loaded the drivers for the motherboard.
Now when I try install SP2 it give me a file is corrupt message. It does that with several programs. I looked at my hardware manager and windows thinks my drive is a SCSI drive.

So I reinstall. This was extremmly painful as the install kept being unable to find files and such.
After many atempts, windows reinstalls w/the same problems.

Any help or ideas?

I looked at my hardware manager and windows thinks my drive is a SCSI drive.

Interesting... What exactly does Device Manager say in that regard?

Under disk drives It list my seagate drive as ST380011A SCSI Disk device
When it should be ATA.

Yes- that model is (obviously) not a SCSI drive.

The reason I asked is that drives connected to some RAID controllers (or RAID-capable motherboards) get reported/identified as SCSI drives.

Is this a possiblity?

Although I could be way off base on this, if you can give us the exact make/model of your motherboard that might help.

The motherboard is an Biostar M7NCD with NVidia Force2 chipset.

The drive being identified as SCSI really sounds to me like it has something to do with the fact that your motherboard has SATA and RAID capabilities, although I don't know if that has anything to do with the problems you're having.

Have a look at the hard drive and RAID options in the BIOS. Turn off the RAID-related settings there and see if that changes anything.

There are not any RAID options in BIOS, unfortunately.

I am wondering if there are other BIOS settings that would change things.
I am grasping at straws here.

Hmm- That mobo is at least RAID-capable; maybe RAID is an option that's only available on some versions of the board.

What are the exact errors that you're getting concerning file corruption?

Last night the system was crashing so much that I tried to reinstall. It won't. When it tries to load the files during install I get file is corrupt use ESC to skip, enter to retry or F3 to quit. Most files a can retry and continue at least one or two won't retry. If I start over same thing. The files that it pukes on are different each time.

I got through the file load. Now when it tries to install devices it will either give a stop error of 0x00000050, or 0x00000024 or just reboot by itself.

I realize that reinstalling was a bad idea.

Help I cannot get XP to install now. I get the "file xxxx.xx could not be written press enter to retry" message. At least one file will not retry. Install continues but will hang or give stop error 0x00000050.

I read somewhere that maybe the new CDROM/R/RW could be the reason for the file was incorrectly written error, so I replaced with my old CDROM, no help
I have tried both a clean install and a repaired install make no difference.

I am at the end of my rope with this one. Any help please.

The XP install disk worked fine with my old system, so I think that is not the problem, that and it is a different file that pukes each attempt.

I am going to try a different video card. All the other hardware is new or was in perfect working order.

If I get another stop code I will include all of the info on the page.

You've mentioned 512Mb of RAM. Is that 2 x 256Mb modules? If so are they the same brand or different modules?

It's a single stick of 512Mb memory.

Last night, I tried two different video cards I get this stop code during the install.

stop code 0x00000050(0xF80CFBC4,0x00000000,0xF84F034F,0x00000000)
setupdd.sys-address F84F034F Base at F84A1000, Datestamp 3d6dd67f

I tried to install Win98SE also. It installed but crashed repeatedly.Completely unusable.

I suspect it's a faulty or incompatible RAM module. I'd try borrowing another from somewhere and seeing if it works with different RAM in it.

Reset CMOS and try again first though.

After reading the link provided, I came to that same conclusion.
So, I went to the manufactuers website, apparenttly this happens alot with mushkin memory.

Thanks for all the suggestions. Hopefully I can get replacement memory Post Haste.

I recieved my new replacement memory last night, Windows XP install without a hitch.

hardware manager stills shows my hard drive and my cdrom as scsi,
but everything works fine, so far.

Unless it starts causing problems, I am going to let sleepings dogs lie.

hardware manager stills shows my hard drive and my cdrom as scsi, but everything works fine, so far.

Unless it starts causing problems, I am going to let sleepings dogs lie.

My hunch is still that the SCSI issue is RAID-related, but as you said, if it's working fine...