1

My computer has USB keyboard and mouse. After using the Windows installer to install Ubuntu on my system and rebooting, the duel-boot menu popped up where I can select either Windosw 7 or Ubuntu. The problem is that my keyboard doesn't work at that point because it is USB, so I can't change the selection.

Anyone know a work around? PS2 or serial keyboard is not an option because my motherboard doesn't have either port. Can I change the default option while in Windows then reboot, and do the same in Ubuntu before rebooting? If so, how?

Edited by Ancient Dragon

5
Contributors
8
Replies
11
Views
5 Years
Discussion Span
Last Post by elhijodelpeje
0

On my motherboard, I have to change a USB setting in the bios to get my keyboard to work with Grub. What motherboard do you have? Perhaps there is a similar setting on yours.

Am I correct in assuming that you used the Wubi installer to install Ubuntu? If so, I think it uses MS's boot loader and not Grub. You can edit entries with BCDEdit (How to use BCDEdit).

If you want to edit Grub options, you can edit /boot/grub/menu.lst .

0

It's a problem with the Windows bootloader (or bios configuration). Wubi only adds an entry to the Windows bootloader.

I have a USB wireless mouse/keyboard and never had any problems with using it in the Windows bootloader (or in Grub2 after that). So, a USB keyboard should definitely work, check your bios settings (assuming you can access them, does your keyboard work before you get to the bootloader?) or look for a solution specific to your computer model.

You can edit the priorities with EasyBCD. I guess you might be able to put Ubuntu as default, and then boot to Windows through the Grub2 menu that comes afterwards. Of course, that's just a temporary solution, until you figure out what is wrong with Windows' bootloader.

0

As Chri suggested, using Wubi might be a good idea. I had the same problem when I installed Ubuntu from disk/usb. I'd suggest uninstalling ubuntu from windows (control panel) and reinstall using Wubi (which installs ubuntu from windows gui and allows for partitioning i believe if you don't already have a partition set up).

0

Update: I used bcdedit.exe to change the default settings, and now I can't boot the computer at all because ubuntu installation apparently failed and the screen just shows a redish colored screen when it attempts to boot to ubuntu. I'm writing this post on another one of my computers. I'll check out the suggestion to see if there is a mother board setting, can't get to the bios either because no keyboard that works.

0

can't get to the bios either because no keyboard that works.

I guessed that. This is weird. Is your keyboard special? If it is, then try a very basic USB keyboard (with no fancy features). Having no keyboard available during the bios / bootloader phase is not normal, nor acceptable. It must be a problem with your computer model.

0

There is nothing special about the keyboard except it has eluminated keys. Its a Logitech that I bought off-the-shelf at Best Buy.

0

To fix your boot, after messing aroung with bcdedit, try Boor Repair Disk, http://sourceforge.net/p/boot-repair-cd/home/Home/ download from another pc follow instructions on same page. AS for the USB keyboard, I have installed most of linux distros on MULTI-BOOT with my Win7, without the reported problem, both with my Microsoft Laser wireless Keyboard/Mouse combo, and with my USB wired Keyboard/Mouse. I would suggest reinstall your linux, and DO NOT PLAY WITH YOUR MOUSE NOR TOUCH YOUR KEYBOARD UNLESS REQUIRED BY THE INSTALL PROCESS. Some linux distros are too sensitive when detecting hardware. Regards

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.