0

Hi all, I'm new here, and a newbie to techie stuff as well.

I found many topics on similar problems in this forums, but none of those solutions or suggestions could help me.

My operating system is windows xp pro. I use both IE7 and Firefox to browse. I use both a desktop and laptop pc, connected via an ADSL Router to the internet.

My problem:

I host a few of my own domains on 2 different servers (shared hosting) at two different hosting companies.

2 weeks ago, while I was transferring one of my websites from one hosting companie's server to another one, the domain name resolved perfectly, and everybody can access the domain without problems, accept me. All my other sites, on both servers ( at the 2 different hosting companies) suddenly I also have problems to load in my browser. Eventually I get all my sites loaded into my browsers, but it takes forever... (5 minutes or longer) and this happens on both IE7 and Firefox. I checked with friends from around the world, as well as in my own country, and all of them can open any of my sites very quick, as it used to be with myself.

I tried all the solutions recommended on other threats in this forums, and none solved my problem.

I spoke to the hosting companies to check the servers, and they were fine. ( Others can browse the websites) and at dnsstuff I pinged all of them, and they pinged fine. From my cmd prompt I pinged them as well, also no problems there.

I signed up with a different ISP, temporary, to see if it may be my ISP, but also, same story, I still take a long time to load my own sites.

I checked all of my sourcecodes for possible problems, and found none. (others can surf those websites)

I scanned, disenfected, restored, re scanned, cleaned and cleaned and cleaned my Pc's and still this problem is there.

I can load every other site on the www without any problem, except my own sites that I am hosting myself on a shared hosting account. I can even open anyones site that is sharing the asame IP as my own sites.

Once my cpanel of any of my sites loaded after a long time, and I'm logged into cpanel, then I can move around cpanel very quickly, without problems.

I am batteling with this problem for 2 weeks now, resulting in me not updating any of my sites, as it takes me about 30 minutes just to login.

Most of these sites are geeglog based, but some are only a normal html index page.

Any help please, I am realy fedup, and don't know what else to do. If there is a known solution to this posted anywhere else, I appologise, as I might have missed it, and then just direct me there please.

Regards

Kraai.

2
Contributors
8
Replies
9
Views
9 Years
Discussion Span
Last Post by Michael_Knight
0

Hi, Welcome to DaniWeb.

If you try to access your sites from http://www.megaproxy.com do they display ok?

Also, try clearing out the DNS Cache on your pc.

Press Start > Run > type cmd clcik OK. Type ipconfig /flushdns and press Enter.

Also, Add your sites to the Trusted Sites in your browsers, that sometimes helps.

0

Hi Michael_Knight

Thank you so much for responding to my problem.

1. Wow, when I use the proxy surfing at megaproxy.com, all my sites opens with 'n flash of lightning speed. What does this means?

2. I also did the DNS Cache flush as you suggested, tried to open one of my sites thereafter, but still, they took about 4 to 5 minutes to load.

3. I have previously added the sites to trusted sites as suggested somewhere else in this forums, changed the tls settings, and all of that, and none of it helped.

With the proxy surfing, I feel we are on to something. Please let me know what do you think this means, as I can open the sites very quick behind that proxy.

Thanks

Kraai

0

Hi Kraai

With your sites opening with a proxy, it defiantly tells us that there is an issue with your connection or ISP.

This could be due to the following:

  • Firewall issue - Something has been blocked on your pc or your Router is blocking certan ports or websites
  • You ISP's routing has problems. Might me worth doing a trace from your IP to your webtites IP and see if it times out

As temporary fix, you can add your website and its IP to your windows Hosts file

Press Start > Run and type drivers and click OK, Double click the etc folder. Right click on the Hosts file (there are a few in here called hosts, so it should be the top entry Hosts, not Hosts.msn or lmHosts.sam, leave these alone) and open Hosts in Notepad.

Under 127.0.0.0 localhost

Add:

YourWebsite IP websitename.com

E.g

63.214.247.170 daniweb.com

Then click File > Save and Close the window.

Try your website now, and do this for the site on your other host. This should bypass and routing table and allow you to view your sites.

If this fails, then its a firewall or local routing issue, or down to your ISP.

Let us know how you get on.

0

Hi Michael

Thank you so much in helping me here.
I have done as suggested, adding the ip numbers to the hosts file, but when I want to save the file, I get a message "Cannot create the C:\WINDOWS\system32\drivers\ect\hosts file"..... "Make sure that the filename and path are correct".....
I saw that the hosts file is "read only" and maybe that is why I can't save it? If so, how do I make it "editable"?

I also saw that "Spybot search and Destroy" added a lot of sites in that hosts file, with the IP: 127.0.0.1. Should I leave them there, as they look like shady tipe of sites to me and I believe the intention with spybot is to block those sites, and I have no problem with that.

As mentioned before, I did test my browsing on another ISP, with the same results, but I must ad, that in the Country I am living, all ISP's are resellers of our Telkom company who is goverment owned, and therefore are routing all ISP's via our Telkom Network.

If this is a router issue locally with me, once I have accessed my router, I turned off the router firewall, and still no improvement. Where in the router should I check for a blocked website or port?

But for now, I will concentrate to get my webhosting IP's listed in the hosts file, so please, how can I make it editable in order for me to save it again?

Many thanks

Kraai

Thanks for your help, I realy appreciate it, as I am not formally trained in all of this, and learns a lot just by being a member here.

0

Hey

That's one reason I don't use Spybot. Your Hosts file should be left blank, as it can damage your browsing experience.

I would recommend using the AdBlock extension with Firefox and remove Spybot Search & Destroy. If you want protection still against Spyware, download and install Windows Defender from Microsoft.

In Spybot, you can disable the read only option of the hosts file in the settings, this will allow you to make the changes.

On restarting the option, Spybot will warn you of the change, just Allow it.

This should hep, any problems let me know.

On a lighter note, you seem to have learned loads about hosting and moving your website, no easy task, especially if there are databases involved. So, its good to see you learning fast.

Let us know if we can help in anyway, also any problems with the hosts file, you can always post here or remove Spybot.

0

Hey Michael

Thanks, I could remove the read only on the hosts file in spybot, and managed to ad my site IP number and domain name just below the entry "local host" as you suggested, saved and closed, reopened it again, just to check if it was saved, and yes, it saved this time. I also removed all the spybot entries in the hosts file as well, and uninstall spybot.

The sad story is, it did not do anything to make me open my site any faster, still on the 4 - 5 minute "waiting for website....." story.

If I follow you correctly, what is left now, is the router and or ISP routing.

I will launch a querie today at our telkom directly, to test my settings and relays to see if they are the culprets.

If there is anything else you can suggest, I will be thankfull.

I will let you all know here what happened on the telkom isp tests, but it may take them longer than a day or two.... (customer service is usually poor....)

Thanks

Kraai

0

Hi again

Report back:

My problem is solved, I can't believe it, and thanks to Michael Knight and this Daniweb forums, I am much wiser as previously.

It was a DNS issue with our main provider Telkom. As I understand it, they had network issues and damaged cables ect. All these issues happened in the past two weeks, same time as I was moving my sites to another server, and this means that my new location DNS was not propperly resolved for a few affected areas, of which I was in one.

It is resolved now, and I can access my sites like anyone else could.

I learned a lot here, and can now start concentrating in getting a bigger knowledge of all the other techie stuff that is available here on Daniweb.

To Michael, with his compliment to me, moving my Mysql database ect, thanks for that Michael, actually, I am still very much lost when it comes to the innerside of these databasis, but moving them, as you will know, is not that hard, in MyphpAdmin, just to export and import it again and changing the config files to include the new login passwords and new databasis names. That was the easy part, thanks to cpanel.

Now, let me learn more here on this site, thanks to all.

Regards

Kraai

0

You're welcome. Glad we could help.

You might want to look at this freeware program, created by MySQL. This will help you backup your database and restore it: http://www.mysql.com/products/tools/administrator/ and also, next time you want to migrate your database from one site to another, there's always the MySQL Migration Toolkit (also comes with MySQL Administrator and Query Browser): http://dev.mysql.com/downloads/gui-tools/5.0.html

I'm glad you got your connection fixed. If you actually live near the Middle East or the Persian Gulf, then I would have expected you to have bad internet due to the cables in the sea being cut.

Glad we could help.

Thanks again and good luck.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.