0

Hey, it's me again. I have a Disk Read Error and I have a paper due this week once again. This happened to me a few years ago, and I asked for help on this forum. Now a few years later, with a new HDD I have the same problem.

I restarted my computer (forced) while it was shutting down (I think, because monitor cable was loose, and I coudn't see the screen.)

Is there a solution besides reformatting? Or live disk (linux) which I am already doing. I need to burn off all my stuff.

Thank you. Any advice would be helpful.

The master drive is a 120 GB Seagate and Slave drive is Hitachi 160 drive.

4
Contributors
21
Replies
22
Views
9 Years
Discussion Span
Last Post by Suspishio
0

Try chkdsk /f on both drives.
Do you have S.M.A.R.T. turned on?
This usually enabled in the BIOS and may give you some useful info.

0

I can't put in commands because windows doesn't boot.
I put in Windows XP/boot up cd and it goes black after it checks my system. I put in Ubuntu and it detected my master drive along with my bios.

I have S.M.A.R.T. Disable I'll try to enable it to see if I can see what's wrong.

Thanks, keep the tips coming because =( I'm seriously depressed.

Also, since Windows Bootdisk doesn't work does that mean this drive is physicallyl broken? As in I have to throw it away after I'm done with it?

0

You could put the drive into another PC via a USB enclosure and chkdsk /f there. Chances are that repaired errors will not have left your boot area or OS files in a state of grace (50/50) and you'll then have to set up windows again or even rewrite your master boot record.

0

So, I take it out, slave it and attach it to another computer? Alright, will due, I would try all this tomorrow moring it's currently 1:35Am in my area, so I'm off please continue discussing or linking me to other who have posted the same errors as me because I looked as much as I can and can not find any solutions that are closely related to mine on this forum.


Thanks again.

Also want to make note that I forcefully hit the restart button while I blindly (no monitor so just guessing) while it was shutting down. So either it was shutting down or updating a game I hit restart due to the fact i took out the dvi-cable.

0

Yeah - there are loads of posts with the same trouble as yours. All expressed slightly differently, but a corrupted disk is a corrupted disk and the range of solutions is very limited.

basically correect the bad block and get the data right again. If it's a boot area or an OS file, it needs resetting.

While you're slaved, get the data off that you might need again.

0

Bad block? I have no idea what is wrong with it. I have a feeling it's a physical damage and praying I can fix it. I just wanted to say one las t thing before bed is that S.M.A.R.T. stated it was damaged and that's about it, gonna try hooking it up tomorrow.

Honestly deep down, thanks alot.

0

Bad block is physical damage at the data block level. A scratch on the disk, for example - and just where you don't need it.

Chkdsk /f fixes this by remapping the disk round the bad block(s), but can't be sure to recover what was in the block(s).

0

Knoppix can't "mount" the corrupt master drive. I assume this means that it means open, which means it's scratched as Suspishio stated.

I can't get windows to load and I can't load Windows XP Bootup disk.

I'm going to slave it now to my other hard drive. What if that doesn't work? Throw it away? I need valuable data. =(

0

I placed in the seagate as a slave, and when it loaded the other drive as master it said the slave (seagate/what i'm trying to fix) that it was corrupt and continue to boot BUT it started windows and deleting stuff and corrupting it was scrolling to fast. I just shut it down. That's bad I know but should have I continued it?

0

Alright, I'll do it again, and let it continue, thanks man.

Sorry for keeping bumping this so much, just worried about data... =]

0

"deleting stuff" isn't informative I'm afraid. "Stuff" on which drive?

The best way of slaving the disk is to put it into a USB enclosure. Then it's not under BIOS control but fully under your control for getting stuff off if it's not corrupted beyond usability.

0

You haven't explained what disk suffered deleting stuff. Sorry this is such a drawn out problem for you.

I would have put the Seagate into an external USB enclosure so that it could be manipulated under my control and not by the BIOS.

0

Interesting read! in my years of hooking up bad drives as a slave drive,internally and with usb device have i seen the good winxp start deleting "stuff" from the bad slave drive

0

I've never seen Windows deleting stuff off the drive in the USB enclosure. Doesn't mean caperjack's wrong - just my years of doing likewise has been different.

So caution, there too, Smartedpanda.

My instincts would always tell me to hook up via USB and I've saved a good many that way - at least the undamaged data.

@ caperjack:
From your observations, whathas been deleted? Anything or Windows system stuff?

0

@ caperjack:
From your observations, whathas been deleted? Anything or Windows system stuff?

Don't know !!
In my post above I said I have never seen windows delete stuff from a slave drive. !!
never seen windows on bootup delete anything the operator didn't command windows to do!

0

Don't know !!
In my post above I said I have never seen windows delete stuff from a slave drive. !!
never seen windows on bootup delete anything the operator didn't command windows to do!

The word "never" was missing from your earlier post, hence my question to you.

0

It was scrolling down too fast, it was a block of "Corrupt Files" and then I saw "Deleting" and like maybe 2 "Rewritting"

It was deleting info off my slave drive which is the one that's f0ked up. Its currently connect to an USB exclosure and can't not be read...What now?

0

That's normal behavior for chkdsk.
Let chkdsk /f run to the end and you should be good to go.
If you still get SMART errors, replace the drive.

0

Yeah, I put it in an external, and now I lost all my personal files, and just have windows folder left...that means reformat. At least the drive works now.

Thanks for everyone who tried to help me, but *@#$q#^$#%$ I needed my files bad.

0

Smartedpanda

Sorry to read that you've lost your files. If the disk was damaged where your files were, you had lost them anyway. We couldn't find this out until the situation had been brought under some degree, at least, of control.

Best of luck with your paper.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.