0

I recently ran spybot s/d and adware to check for and immunize pop ups I am getting. I have done this before with no problems in the past. After the recent running of these programs, I have no Autoexec.bat files. When I run sysedit the screen comes up as it can not read the autoexec.bat file. This problem is affecting one program that needs a command in the autoexec.bat file. When I add the path needed in the autoexec.bat file, it does not save after saving the file and rebooting.
Does anyone have any ideas why auto exec.bat will not save the paths or any other ideas??
thanks
firedad

2
Contributors
9
Replies
10
Views
12 Years
Discussion Span
Last Post by DMR
0

Just to clarify-

1. You're saying that it didn't work even when you created a new autoexec.bat file, added the necessary entries there, and then saved the file to the proper location (C:\)?

2. The file you created doesn't contain the entries any more once you reboot? What exectly is in the file at that point; anything?

0

correct

There is nothing in the autoexec.bat file. As I stated, when I attempt to run sysedit. a window pops up stating the system can not read the auto exec.bat file. I hit OK and the .bat file comes up empty.
I deleted the .bat file and recreated it, restarted the machine and still nothing?
No other problems with running any other programs. Norton antiVirus came up with nothing either.

0

I deleted the .bat file and recreated it

Yes... that is what I'm asking about. How exactly did you "recreate" the file and what exact entries did you put in it?

You might be lucky enough to have a backup version of autoexec.bat on your system somewhere which, even though it might need a little editing, would at least give you a basic template to start with. Search your system for other files named autoexec (they'll probably have an extention other than ".BAT"; perhaps .BAK or .NSW).

0

I deleted it in dos and replaced it in dos mode. I then attempted to edit the .bat file in dos (the blue screen section) by adding the path necessary to run my program. After closing dos and running sysedit, the path was in the .bat file. I rebooted the machine and the syseditor says it is can open this file. The path added in dos was not there. This is no different before and after deleting the .bat file

The Autoexec.bat file is till there I ran the file search and the .bat file is there (created in '99). It also comes up when I run the sysedit program, but a error message comes up stating "System config editor; Autoexec.bat cannot open this file"
I click OK and the windows in the system config editor come up but the .bat file is empty. I add the path I need to run my program, reboot, open sysedit and the same error message comes up.. the path I just added is not there again.

0

That's pretty strange- just a longshot, but is it perhaps a question of the autoexec.bat file having its read-only attribute set?

0

That's pretty strange- just a longshot, but is it perhaps a question of the autoexec.bat file having its read-only attribute set?

The read only box was not checked, I have tried to recreate the .bat file as a read only. It stays put but my program still will not run.. If I uncheck the read only box, the .bat file goes away.
I have also posted this issue as a security/virus problem to see if anyone many have heard of any viruses that wipe out .bat files
Firedad

0

FYI

I have spoken to the product support for the program I use and he suggested that Norton,spybot, or ad-aware may be seeing the info in the autoexec.bat file as something that is being added and is deleting them at start up. This program I use needs a command in the autoexec.bat file to run( It is an older court reporting program)
Firedad

0

Call off the jam!!
The problem seems to be tied to some spyware removed by HJT. After I removed the probelms, I reinstalled the program giving me problems and now everything is working fine..............for now
Thanks for helping out.
Firedad

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.