0

I have a home network with three desktops running XP SP2 and a laptop running Vista Business.

I would like to use Windows Remote Desktop Web service to control and access my desktops from my laptop (via broadband wireless) while I am away from home. I have used Webex’s PCNow but I can’t justify the monthly fee. I have been using Logmein.com for a week now but the free version doesn’t offer all the services I would like.

I can’t get Remote Desktop Web to work. I have searched and tried suggestions already offered on Daniweb but nothing has worked. I keep repeating the same step-by-step procedures with no success.

I followed all the instructions, setting the port forwarding in my router, installing the software, activex controls and starting the w3svc service and running the remote desktop web client. I disabled all firewalls, spyware and virus software.

I tried to remotely access (through my laptop broadband wireless) my home desktops through the IP address that my router reported. http://MY.COMCAST.PROVIDED.IPADDRESS/tsweb. It can’t find the server.

I took the router out and connected one desktop directly to the cable modem. The PCs network adapter reported a different Comcast Provided IP Address than the router. I tried the same thing with this IP address. It still can’t find the server. I tried it again without the router but with the router reported IP address. It still didn’t work. I can’t think of what to try next. Does anyone have any ideas?

I am using a Linksys WRT54GS router with the newest firmware. All my computers are up to date with windows update service.

Al Teal in Hinesville, Georgia, USA

3
Contributors
12
Replies
13
Views
9 Years
Discussion Span
Last Post by Al Teal
0

Try to connect your laptop to your desktop on your side of the firewall first. Once you have that capability, then you can try to make it through the firewall. Make sure you have enabled Remote Desktop on the PC you want to access remotely. You can find this setting by right-clicking on my computer, going to properties, selecting the remote tab, and clicking the allow users to connect remotely checkbox. One last thing, if you don't have a static IP for your router, you won't know when your IP changes unless you check it constantly.

0

I definitely do have remote access enabled. I have connected my remote host directly to the cable modem without a router and with all firewalls disabled. Then I tried to login from my broadband wireless laptop client using the IP address reported by the network adapter in the host. It still could not locate the server.

With my host computer connected to the PC side of my router, I am going to see what happens if I connect my laptop (via ethernet cable) to the internet side of the router uplink and try to open the host as if my laptop were the internet.

I would be trying that right now but I am not at home. I'll be home in a couple of hours and will try it then. But, if that works, I don't know what I will do next. I hope nothing explodes.

Al Teal

0

I don't have a static IP address but it doesn't change often. I have also used a DNS service and the remote desktop web doesn't work with it either.

0


With my host computer connected to the PC side of my router, I am going to see what happens if I connect my laptop (via ethernet cable) to the internet side of the router uplink and try to open the host as if my laptop were the internet.

I would be trying that right now but I am not at home. I'll be home in a couple of hours and will try it then. But, if that works, I don't know what I will do next. I hope nothing explodes.

Al Teal

I knew it wouldn't work but I tried it anyway.

I know it isn't a problem resolving my dynamic IP address because Logmein and PCNow works. Does anyone have any more ideas?

0

Dont ask me how this matters or why, but i resolved a similar issue with remote desktop by making sure i created administrator user accounts on each PC and logged in with a password on boot.....bingo! it worked for me.

I was accessing my other systems from within my own LAN however so i guess you may need to have your hardware firewall turned off within the router to see if connection can be established this way even though you have it configured to forwarded the port.

0

Dont ask me how this matters or why, but i resolved a similar issue with remote desktop by making sure i created administrator user accounts on each PC and logged in with a password on boot.....bingo! it worked for me.

I was accessing my other systems from within my own LAN however so i guess you may need to have your hardware firewall turned off within the router to see if connection can be established this way even though you have it configured to forwarded the port.

Thanks for responding, digitalocksmith.

Remote Desktop works perfectly within my LAN but not at all through my internet connection (cable modem.)

I disabled all malware monitors and firewalls (hardware and software) on the host and client computers during my troubleshooting attempts. It is as if my ISP, Comcast, is intercepting the request from the Remote Desktop Web client on my laptop and not allowing it through to my cable modem where the Remote Desktop Web host computer resides.

This should be a simple problem to solve. I thought I was pretty adept at simple LAN/WAN interactions. I need to figure this out for sanity's sake but I will take any help I can get.

All I know how to do right now is repeat actions that I know won't work.

0

Yeah.....I dont think its possibly an issue with your ISP restricting access to the modem (although we all know how crazy they are becoming these days), its got to be an issue with the router and its command to forward that request (port) to a specific IP on the LAN (that of the host).

Are you positive that you have configured the router to forward the correct port to the local machine for these remote requests????
I think the port used by Remote Desktop is 3389 (I think its the same as terminal services).

Regards

0

I have the 3389 port forwarded to the local host's IP. I have also tried it through other random ports.

It appears that I didn't have all the router firewall features turned off, so I turned them off, disabled all the malware monitoring software and services, went through the entire process again. All the remote access services and features were enabled.

Now, I can get a response to a ping with the dynamic IP address and through my DNS service name but still cannot connect to the remote host.

I still think it is something simple.

0

I have been working on this from time to time since my last post.

I am at knocking at the last door to getting through to my remote desktop web (RDW) host computer on my home network, I think.

Not all the information needed to completely set up the RDW connection is in one place. I read many documents before I found out that my host computer on my LAN had to have a static IP. I understand why but did not think of it until I read it.

I can now browse to http(colon)//myfake.dnsservice.org:3389/tsweb, and will get the tsweb/default.htm login page. The page definitely was served by my host computer, but I still cannot connect to it to remotely control it. After more searching, today I read that I have to have a server certificate installed on the host before my client will be able to get remote control.

Now I have applied for a server certificate but have yet to receive a reply. It is Sunday at 11:00 PM here in Georgia so I do not expect a reply before Monday business hours.

I have more questions. Do you really need a server certificate to connect to and from your personal computers? If so, is there any way around it? Is there a way to manually create a server certificate for your exclusive personal use?

Al Teal

0

I have the first success using Remote Desktop Web on a laptop running XP Media Center OS. It works great but the laptop I use most is running Vista Business. When I click "Connect" on the Remote Desktop Web page, I get a message and some data:

Problems with this Web page might prevent it from being displayed properly or function ing properly.

Line: 239
Char: 4
Error: Permission denied
Code: 0
URL: my.dynamic.dns:myport/tsweb

Digitalocksmith or anyone else recognize that?

0

I have finally gotten it. The Remote Desktop Web service works with my Vista Business laptop client.

Thank you for the help, Digitalocksmith.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.