I have XP Home
My computer just recovered from PSU failure.
Now I click on the desktop icons and nothing happens - no hour glass no starting of programs. The Icon dims.
I have made new icons and the same thing happens to the new ones.
The icons on any active window do not work either. The only way I can get ontrol panel to open is to switch to category view. The classic view icons do not work.
Programs do open from the start menu
Cannot open c: drive from MY Computer
Everything does work from windows exporer.

I just discovered that right clicking and choosing "open" or "run as" does work but not clicking the left ouse button.
I switched mice. Same result.

Any ideas? Please help!

First off go into your mouse set-up in control panel and check the operation of your buttons there. If the mouse works well there I would repair windows from your CD on a boot install.. Boot your PC with your windows CD and wait untill it finds your copy of windows and asks if you want to repair, click "R" and allow it to repair you installation. It might look like a fresh install but it is just repairing windows. When asked if you want to register windows, click not now as it is registered still.

Anne, this should do the trick. I have included some links as a way of acknowledging the author of the fix.
Home - http://www.dougknox.com/
Links - http://www.dougknox.com/xp/xp_fixes.html
The link - http://www.dougknox.com/xp/fileassoc/linkfile_fix.zip
==Please copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixkey.reg, as type "all files", to your desktop; dclick it to run... agree; if it opens in notepad instead rclick the icon [file], choose Open with, Registry editor....

Windows Registry Editor Version 5.00







"Command"="rundll32.exe appwiz.cpl,NewLinkHere %1"





[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\Offline Files]





[HKEY_CLASSES_ROOT\lnkfile\shellex\PropertySheetHandlers\ShimLayer Property Page]









I was hoping not o have to do that because it scares me. I do not want to lose any of my data.
I guess it is the only thing left I haven't tried.

Thanks, Gerbil, that did it but I had to delete and redo all the icons.

Sometimes things in the registry just get broken, Anne, and there is no option but to fix them. Glad it worked for you. Cheers.