When I click on a link, like the one when I signed up for this forum does not work. I have to paste the shortcut in the address bar and this is not always available. Clinking the links have worked and now for about a week they do not work at all. when I click on a link it just hangs there and never loads. I'm using win xp and IE and I also have firefox installed but the links do not work. I ran my virus programs and turned off my firewall and allowed my blocked popup to allow the link but nothing works to load the link. Help please.

try this i see nit work before for this issue ,
open IE ,and go to tools /internet options /programs ,and down the bottom check off internet explorer should check to see if its the default browser .if it check on check it and close browser and then go back in and check it off again

The IE was not checked, I checked it closed and reopened the IE unchecked it and still can not open the links. Especially the one that came with the notice that I had a reply to my post.

so you are talking about links in a email program,what email program are you using ,outlook express by chance
edit .try this .
Tools, Internet Options, Advanced
restore defaults at the bottom

Email is a problem and any program I try to access, especially a link to download more info about something. It happens at all times and locations.

try this from this site,i know you links will not work so i posted partial content ,of course you could copy paste url
http://www.helpwithmypc.info/pc-help/hyperlinks-not-working-in-outlook-express.php

File Association for web pages could be wrong

With all files on your system Windows needs to know which application to run to open the file. For example the ".doc" file extension would open Microsoft Word if you had Word installed on your PC. The same is with web pages, Windows needs to know that for certain pages it needs to open your browser. To change this follow these steps:


1. Click Start, point to Programs, point to Accessories, and then click Windows Explorer.


2. Click Tools, click Folder Options, and then click File Types.


3. In the Registered File Types box, click URL:File Transfer Protocol, and then click Advanced.


4. In the Actions box, click Open, and then click Advanced.


5. The Application Used To Perform Action box may display the path to your Web browser as a short file name or as an incorrect path. Type the path to your Web browser with the full file name. For example, the following path may appear in the Application Used To Perform Action box.
c:\progra~1\intern~1\iexplore.exe
Change the path to the following path:
"c:\program files\internet explorer\iexplore.exe" (including the quotation marks).


6. Click OK, and then click Close.


7. Repeat steps 3-6 for the following registered file types:
• URL:Gopher Protocol
• URL:Hypertext Transfer Protocol
• URL:Hypertext Transfer protocol with Privacy
• URL:Internet Shortcut


8. Click Close.
Note If you follow these steps, you may receive the following prompt when Internet Explorer starts:
Internet Explorer is not currently your default browser. Would you like to make it your default browser?


Make sure that the Internet Explorer should check to see if it is the default browser check box is not selected under Internet Options, or the issue may occur again.


If you click Yes, the issue may occur again.