0

I reformatted my old Maxtor Hard drive (53073U6 - 30gb) with XP following some issues. All of the important data I needed was backed up to a Seagate Barracuda 7200 (120gb).

Previously both hard drives were accessible - the Maxtor jumpers set to Master, the Seagate with no jumpers set to Slave. The cable runs from the Master, via the Slave to the board. Never a problem and although perhaps a bit slow by today's standards, worked well enough for my use.

XP has reinstalled onto the Mastr Drive (Maxtor) with no problems but although I can see the Seagate back up (slave) drive in Device Manager, I cannot get the Drive to open or access any of my critical folders.

At panic stage as I have work files, hundreds of photos and music and do not wish to lose any of them.

What do I need to do to get the slave drive back online without in any way deleting files. (The Slave/Seagate is partioned itself into 3 drives and I wish to access all of them). I understand reformatting may delete a partition but do not wish to try this. I don't understand if initializing the drive as suggested elsewhere may have a similar effect. I have not changed any ofthe BIOS settings but the set up now is exactly as before.

As an alternative, could I just connect the Slave Drive but boot using the Windows XP disk, then access the files and copy onto some form of external storage - in that way it won't matter if I trash the Seagate and start over.

Thanks and thanks again

2
Contributors
27
Replies
28
Views
9 Years
Discussion Span
Last Post by gerbil
0

Hello, james. Your hardware setup is fine. Your problem is that Explorer is not looking at the drive root when it starts, so as to catalogue the root directories.
Can applications access the drive and related files? Possibly not if you have not used them since the reinstallation...
If you open an Explorer window [dclick My Computer] and type the drive letter.. eg. D:\ into the Address Bar does it open in that directory? And can you then move throught the folders therein?
If that does not work can you open the drive via Internet Explorer [type D:\ into the address bar.... etc]?

0

Addressing your other queries.. do not format any partition on that data drive... it will make file recovery a little more tedious.
Does the drive show in Disk Management [via Admin Tools, Comp Mgmnt] ? There should be no need to initialise the drive. Does Disk Management show that as an option?

0

Hi and thanks for looking at my issue.

I have booted the PC and can still see in Device Manager that the second disk (registered as a Seagate Disk etc) is visible, and working normally it says).

I have attempted to trace the partitions by typing in D:/; E:/ etc. without success.

When I enter Disk Management in Administrative Tools; Computor Management; I see the following "volume's":

Volume Layout Type File System Status
(C:) Partition Basic NTFS Healthy (System)
(D:) Partition Basic CDFS Healthy
Photo Album Partition Basic NTFS Healthy (Active)

Directly below I can see the following:

Disk 0 (C:) 28.6GB NTFS Healthy (System)
Disk 1 Photo Album 111.79GB NTFS Healthy (Active)
It then references the CD-ROM again as above.

When I click on the C Drive and review properties, it brings up a pie chart of the disk etc.

However, when I right click on the "photo album" disk, it wither gives me an option to delete partition, or help.

I haven't explored the BIOS but as this is exactly the same confiduration as before, I am at a lost why the foles should remain unavailable.

Furthermore (if this helps) the Seagate Disk had 2 other partitions on it when I backed up data and coped information to it. Both had information in them and are crucial files.

At this stage I am only interested in getting the information out and backed up onto a removable drive - can you help at all?

Thanks again for your support

James

0

Hello, James... u can post screenshots, you know [printscreen, then Accessories, Paint, paste into it], but I get the picture from your description.
You are seeing the optical drive in Disk Mgmnt cos you have a cd in the drive, hence the CDFS partition -that is of no concern. What is interesting is that the cd drive is shown above the problem hard drive in the first list - in my experience, no matter the drive letter assigned, it should appear at the bottom ie. after the hard drives.
I notice the Photo Album drive has no drive letter assigned. But it is shown as Active?!!
Active means that the PA drive is being used to provide the booting files for Windows; here is a bit of backgrounding for you:

When you first set up the partition(s) on a disk a boot sector will be written for each volume; one, which will be on a primary partition, and one only, must be marked as Active, unless this is a slave or data disk in which case none are marked Active. There will be only one boot sector per volume [volume = drive, if you wish.. eg c:, or d:]. The disk's master boot record will be written at the same time. Only one of these per disk.
XP can be placed in any partition, including logical, by itself.
When it commences loading the OS, BIOS searches for the Master Boot Record on the master disk. The MBR's partition table for that disk is read; the single, active partition is noted; the MBR code is loaded into memory, and BIOS hands control to that. The MBR code directs operations to the partition marked as active, specifically to its boot sector. All partitions contain the same boot sector code, but only that active partition's boot sector code is loaded; it assumes control and searches for certain files in the root of that partition. If your OS is XP then ntldr will be read into RAM and ntdetect.com will examine your hardware [and either BIOS or Windows will assign resources to them depending on whether you have ACPI].
ntldr will read boot.ini and depending upon your configuation you may be presented with a choice of operating systems to load. And on it goes...

Okay, that is just a paste from something I wrote for someone else, but it may clarify these next points for you.
-because C: is reported as your System drive [M$ speak for the drive with your boot files] check in the root of your C: drive for these [the boot] files: boot.ini, ntldr and ntdetect.com. You will have to set Folder Options, View, to not Hide Protected Op Sys files. If these files exist in C:\ you may use Disk Mgmnt to set C: as the Active partition. Then make sure that in BIOS Setup the disk with C: is set as first in the boot order, that your sys restarts... and then use DM to remove the Active setting from the PA drive.
-it may be that if you create another user account with Admin privileges your problem will disappear.
-If that does not work then let's force Windows to re-read all the partition information from each disk and rewrite a new set into the registry.... [this will not damage your hard disk info]
--go Start, run, and enter regedit.
--navigate to this key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]
----in the left column expand MountPoints2, then highlight and delete the subkey CPC [and only subkey CPC...]
--restart your computer. MountPoint2\CPC should then be re-created.
[the CPC subkey contains info about each installed drive.. ie. each hard drive partition and each installed mountable drive... floppy, optical... the information is drive number, name, disk signature if it exists and partition info].
Anyway.. what happened? Did any suggestion work?

0

Hi Gerbil

Firstly, many thanks for your patience - I work away and getting to complete some of the tasks advised takes a few days.

I have tried all the above but in summary, have not been able to resolve. I would make some comments as below, using screenshots (thanks for the tip) to assist.

1. I removed the CD and now the CD Drive drops to the bottom of the list.
2. I checked in my C Drive and found the boot files you refer to: boot.ini; nldr and ntdetect.com. The BIOS is set to read the Master (Maxtor) drive first.
3. However, there is still no Drive Letter attached to the "Photo Album" Drive (slave) and it advises that the disk status is Healthy (Unknown Partition). See Screenshot Disk Management 1.
The reason it has changed to Unknown Partition is because a friend helping me, entered C:\DISKPART and through some steps (listing Drive and then Partition) made this partition INACTIVE. We rebooted but nothing changed and I asked him to stop - trusting your advice.

4. I have tried to use DM to make the C: Drive Active, but when I click on it the "Mark Partition as Active" is greyed out and nothing happens. (By the way, if I right click on the PA Drive the only option remains Delete or Help).

5. I have again checked the Device Manager and the Slave Drive (Seagate) still appears - See screenshot Device Manager 1. When I click on properties/volume the following appears against Partition Style: Master Boot Record (MBR) - See screenshot Device Manager 2
I have racked my brains over this and can advise that many moons ago, I decided to move the OS onto the Maxtor (now master drive), making the Seagate a Slave and using this disk with its' larger capacity to be my back up. Does this explain its' status as MBR? Will this prevent me accessing any data in the future? I did not consciously reformat the Seagate (now slave) and am guessing these are residual files?

6. I entered regedit and followed all steps - I'm afraid I didn't capture a screenshot but eventually under CPC it showed:
Volume:
21d48e29-a690-11
68190142-a694-11
68190142-a694-11.

On rebott there was no change to seeing the second drive but the CPC and volumes had been recreated as you suggested.

Still desperately in hope that I can recover my lifes work and really appreciate your support

Thanks

James

Attachments Device_Manager_1.JPG 95.25 KB Device_Manager_2.JPG 123.67 KB Disk_Management_1.JPG 116.28 KB
0

Hello, James.
-Your C: drive is the System drive, it IS being used to boot the system, it is Active [hence that option is greyed out]... I just wished to check before getting you to remove the Active status of the PA drive [seagate]. No active drive woulda made things unnecessarily complicated.
-Re the MBR partition style shown in Volumes tab... that is fine - it is the method Windows hard drives use to record the partition information of the drive, ie. the MBR records the start and length of all partitions on the drive. There is no problem there with files from its previous life.
We can look at the partition information; it may be corrupted. Take care with this tool you will download, don't misuse it. Delete means delete, and so on. But it is easy to use.
Get MBRWhiskey from: http://red.boot-land.net/index.html
Extract the files, MBRWhiskey.exe is the one we are interested in [MBRWiz.exe is command-line only].
Orright, start it [dclick the exe].
=Select Disk:0; go Disk, Save MBR to file, name it MBR_SaveDisk0.dat
=Select Disk:1:, and save its MBR also.
That was for safety, and you can keep those files until you change the disks' partitioning.
=go Extra, Write Disk Structure & Part info to file..., Save it to MyDisksPartInf.ini
Do not be tempted to Repair the MBR - it will only do it for the Active disk, anyway, and that one is okay.
-exit from MBRWhiskey.
-open a notepad, drag MyDisksPartInf.ini into it, and post that.

0

I could add that the window does not fill until you select a disk; when you select Disk1 [the seagate] a screenshot of the populated window would be nice.

0

Hi again

Sorry to appear dull!

I have followed your link as described for MBRWhiskey but cannot find a download per se.

I have downloaded the link at the bottom of the page there (BartPE plug in inlcuded) - is that the right file? It is called MbrWiz, a .7z document!

Given the sensitive description of how to use I don't wish to be clumsy and use it incorrectly.

Btw, I did follow a link to get a file from a linked site called MBR Wiz 2.0 - it's a zip file.

Secondly, can you please describe the additional screenshot you are after - I can't follow - sorry.

Finally, I'm not sure I understand the Active comment - I think it is the Maxtor (Master) that is saying Healthy (System) - as per Disk Management 1 screenshot. The "greyed out" section occurs when I try to click on the Seagate Slave disk, leaving just delete or help visible.

If you can just confirm I'll have a go - once again thanks for your endurance with this request!

Regards

James

0

Hi, James... re that linked page : I often try to give the author's home page to simply give him credit. Bart PE plugin is so that you can integrate the pgm with Bart's PE disc - we are not interested in that. Yep, that is the correct file, it's a .7z, and WINRAR or 7-Zip [both free] will both cope with that. It contains both the GUI and the commandline pgms.
"4. I have tried to use DM to make the C: Drive Active, but when I click on it the "Mark Partition as Active" is greyed out" - it already is Active, so that is fine.
The screenshot: dclick MBRWhiskey.exe to start it; in the HDD box click the down slider, select Drive:1 and the window will populate. Shoot it.
Then go Extra, Write Disk Structure & Part info to file..., Save it to MyDisksPartInf.ini.. drag to a notepad and post it. I have a feeling that this will show that the partition is hidden, or somehow corrupted.
What you could do yourself is read the partition window for Disk:1, and see if any partitions show as hidden. If one does, then simply:
-select that partition in the window,
-go Partition, Unhide.

0

Hi again.

Can I just be certain I'm about to do the right thing - thanks!

I have coped the 2 files (.7z document and MBR Wiz 2.0 - zip).

When I click on the .7z doc it asks for the prog to open it.... Is this what you say WINRAR or 7-zip can cope with (never heard of 7-zip but guess just to type in to the net and download?). The MBR Wiz 2.0 zip file unzips to an exe file - which should I use and is the .7z doc meant to do that?

I think I understand the rest - you'd like 1 screenshot and 1 copy to notepad.

Hope I haven't dulled your mental muscles completely and again thanks

James

0

Hello, James.. I'm not stressing here.. :)
Pleas use the link I gave you and not some other you found - you will get both files.
The .7z unzips to give two files [an html and an inf] plus a folder called files. Inside files you will find MBRWhiskey. Other download sites may not have this.
And off you go with it....
Info: WinRAR and 7-Zip are two file compressor/decompressor softwares, similar to WinZip but dealing with differing compression algorithms. WINRAR is possibly the most comprehensive, but comes with a nag. 7.Zip uses possibly the best algorithms, WinZip is simple but most restricted... argh.. look, the 3 are all different, and you can mostly get by with only 7-Zip. No nag. And straightforward as, it just does the job. Most formats you will come across are covered, but not .iso. So for that you need WinRAR or IsoBuster. Sigh. Have, then, &-Zip and WinRAR.

0

Okaayy.. I just updated 7Zip and WINRAR.... & 7.Zip seems to be the winner for me.. it does iso files now. But I have both. And I am not a software reviewer, just a user of stuff, so I am not making choices based on vanishing margins or other esoterica.

0

Hi again

Ok, I have (I hope) followed your instructions and would comment as follows:

I have opened MBRWhiskey and saved the files as requested. I then moved on and have written to Notepad the ini file. This is attached.

I also took a screenshot as you requested, showing MBR Window open for Disk1. I'm afraid it doesn't show any hidden partitions eeek!

If everything fails, is there any way the data could be recovered?

Thanks as always for your time and patience.

James

Attachments Disk1_screenshotMBR.JPG 128.22 KB
MBRWiz - Version 2.0 **beta** for Windows XP/2K3/PE   February 22, 2006
 Copyright (c) 2002-2006 Roger Layton                    http://mbr.bigr.net
--------------------------------------------------------------------------

[Disk0]
Size=29311
PartitionCount=1
ActivePart=0
Cylinders=3736
Heads=255
SectorsPerTrack=63
Signature=134385e

[Disk0.Partition0]
MBRIndex=0
Type=07
Name=NTFS   
DriveLetter=C:
Label=<None>
Size=29298
Active=Yes
Hidden=No 
StartSector=63
EndSector=60002712
PTStartCylinder=0
PTEndCylinder=1023
PTStartHead=1
PTEndHead=254
PTStartSector=1
PTEndSector=63

[Disk1]
Size=114473
PartitionCount=1
ActivePart=N/A
Cylinders=14593
Heads=255
SectorsPerTrack=63
Signature=cfb1cfb1

[Disk1.Partition0]
MBRIndex=0
Type=44
Name=UNKNWN 
DriveLetter=--
Label=<None>
Size=114470
Active=No 
Hidden=No 
StartSector=63
EndSector=234436482
PTStartCylinder=0
PTEndCylinder=1023
PTStartHead=1
PTEndHead=254
PTStartSector=1
PTEndSector=63

[Disk2]
Size=3935
PartitionCount=1
ActivePart=N/A
Cylinders=501
Heads=255
SectorsPerTrack=63
Signature=efb879a

[Disk2.Partition0]
MBRIndex=0
Type=0C
Name=FAT32X 
DriveLetter=E:
Label=UDISK 2.0
Size=3935
Active=No 
Hidden=No 
StartSector=32
EndSector=8060896
PTStartCylinder=0
PTEndCylinder=383
PTStartHead=1
PTEndHead=15
PTStartSector=1
PTEndSector=32
0

That is what I wanted to see, James. Give this a shot... back into MBRWhiskey, Disk:1, highlight Partition 0 [the only one listed]]... see the type is 44hex? We need to change that to 07, so go Partition > Change type, type 07 into the New type(hex) box, Ok it.
As a side note... in that .ini file you made I believe there is an error [not yours or your disks]: where it says EndSector it should say SectorLength. don't worry about it now.. I just added this in case you use the tool on a multi-partition drive and the info does not add up.. :)

0

Hi again

I have attached a screen shot following the change as advised (Partition 0 to 07) using MBR (it now says FE-UNKNWN). By the way, what does "hex" mean?

I have also attached an update to the ini file you previously requested, post changing the type to 07.

I also have recall to an item you proposed ages ago re Admin rights. On the PC, there is one listed Administrator (Me) only. I have not added another but also do not remember confirming Administration rights during set up (with a password etc). Not sure if this is relevant or helps.

As ever my thanks

James

Attachments MBR_Change_Disk_to_07.JPG 129.73 KB
MBRWiz - Version 2.0 **beta** for Windows XP/2K3/PE   February 22, 2006
 Copyright (c) 2002-2006 Roger Layton                    http://mbr.bigr.net
--------------------------------------------------------------------------

[Disk0]
Size=29311
PartitionCount=1
ActivePart=0
Cylinders=3736
Heads=255
SectorsPerTrack=63
Signature=134385e

[Disk0.Partition0]
MBRIndex=0
Type=07
Name=NTFS   
DriveLetter=C:
Label=<None>
Size=29298
Active=Yes
Hidden=No 
StartSector=63
EndSector=60002712
PTStartCylinder=0
PTEndCylinder=1023
PTStartHead=1
PTEndHead=254
PTStartSector=1
PTEndSector=63

[Disk1]
Size=114473
PartitionCount=1
ActivePart=N/A
Cylinders=14593
Heads=255
SectorsPerTrack=63
Signature=cfb1cfb1

[Disk1.Partition0]
MBRIndex=0
Type=FE
Name=UNKNWN 
DriveLetter=--
Label=<None>
Size=114470
Active=No 
Hidden=No 
StartSector=63
EndSector=234436482
PTStartCylinder=0
PTEndCylinder=1023
PTStartHead=1
PTEndHead=254
PTStartSector=1
PTEndSector=63

[Disk2]
Size=3935
PartitionCount=1
ActivePart=N/A
Cylinders=501
Heads=255
SectorsPerTrack=63
Signature=efb879a

[Disk2.Partition0]
MBRIndex=0
Type=0C
Name=FAT32X 
DriveLetter=E:
Label=UDISK 2.0
Size=3935
Active=No 
Hidden=No 
StartSector=32
EndSector=8060896
PTStartCylinder=0
PTEndCylinder=383
PTStartHead=1
PTEndHead=15
PTStartSector=1
PTEndSector=32
0

Hello, James, that is sad. Well we can leave MBRWhiskey now. Time to get another tool, and this one will take an effort by you. It is not a straightforward download and run software package, so I will give you some instructions. Basically with this tool, Testdisk 6.10, we can bypass the MBR's partition table and just search for the physical partitions on the disk, then bypass file tables to copy out directories complete with files, or individual files.
This tool can also image a disk so that you have a complete backup [complete with errors] if you have a spare disk with at least the same capacity as the Seagate.
PhotoRec ignores basic disk structures and simply hunts for image files.
From this site: http://www.cgsecurity.org/wiki/TestDisk_Download
- download the Windows zip file of Testdisk 6.10, currently the 2nd from top.
- download the documentation bz2 archive.
Create a new folder, name it Disk Tools.
Extract contents of the zip file to a scratch folder, then drag the folder TestDisk-6.10 to Disk Tools, then delete the empty parent TestDisk-6.10-win folder.
Extract "to here" the documentation .tar file from the .bz2 file you downloaded, then extract "to here" from the .tar file the folder testdisk-6.10.
Drag the doc folder from that to Disk Tools\ testdisk-6.10
Easy? You should have:
X:\Disk Tools\TestDisk-6.10\doc + ico + win\.. [you can delete the dos folder]? I dunno what drive you put it on, so I put X:\

To start these tools and read the helpfile you may want to make 3 lil icons for your desktop, thus:
Paste this in a notepad, adjust the path to your own [the X:\ bit...], and save to desktop as TestDisk_Start.cmd

:: starts Testdisk
@ECHO OFF
Start /D"X:\Disk Tools\testdisk-6.10\win" testdisk_win.exe

Again, but this one is TestDisk_Help.cmd:

:: starts Testdisk Help for both Optical and HDDs, with a link to PhotoRec helpfile.
@ECHO OFF
Start /D"X:\Disk Tools\testdisk-6.10\doc" testdisk.html

Again, this one is PhotoRec_Start.cmd

:: starts PhotoRec
@ECHO OFF
Start /D"X:\Disk Tools\testdisk-6.10\win" Photorec_win.exe

Do they work? TestDisk_Start and PhotRec_Start open small black text windows; Testdisk_Help opens an IE html window - this also has the help files for PhotoRec by link on the first page.
Worked? No? Check the paths.... Right, read the help file.
A tip, when in the [black] tool windows pressing "q" will back you out a step at a time, all the way to closing. Very handy for when you get nervous about a task.
I'll be around when you are ready.
PS: hex is for hexadecimal, numbers of base 16, instead of base ten, very handy when dealing with binary numbers and bytes. 07H = 7... Counting is 0 1 2 3 4 5 6 7 8 9 A B C D E F [= 0 to 15 decimal]

0

Hi..... and wow

Falling at the first hurdle but will try and follow your instructions closely!

1.Firstly, my good news - I have an external hard drive @750Gb so plenty of room to copy files (if I get that far)
2. I have downloaded the testdisk file and ,tar file.
3. Created a new folder call Disk Management
4. If I x2 click on the testdisk.zip it opens a folder testdiskfolder - in here are the files which I have copied into a separate folder 3 folders/8 files) called Test 2 (my name) - presume this is a scratch folder?
5. Stuck on the next bit - once I have copied all the files emerging from the testdisk zip and folder o this Test 2, I'm left with both the zip file and folder (I copied the files to Test 2) so it remains populated - mistake?
6. I have stopped at this stage.

Sorry to always appear dull, if I used daily then I'd probably rush through but if ok, can you just confirm I'm on right track and what to do next.

Yikes - hope I get smarter at reading your instructions!!!

Thanks

James

0

Hi there

Please read this before my last missive!

I have followed your instructions hopefully and created a Disk Tools folder that looks like the attached (sceenshot)

I am now going to transfer via USB mini disk to main pc and write in the "lil icons".

And now I guess the BIG test lol!

Btw, thanks for he hex advice - I understand the principle if not the workings.

Appreciated always


James

0

Hi again

Have been trying to attach the screenshot of the Disk Tools folder to show you what files are held in there for "testdisk". Thought I had but re-reading the reply it is missing - apologies.

I don't seem to be able to upload - have tried other screenshots, all seem ok! Saved as a jpeg so no size infringement - perhaps there is a community limit.

So - I copied the file names as follows: Link for me is x:\Disk Tools\testdisk6.10\..... see below (I deleted the dos folder).

ico (folder)
win (folder)
AUTHORS (file)
Changelog (file)
COPYING (file)
documentation (looks like a web page)
INFO (file)
NEWS (file)
README (file)
testdisk-doc-6.10 (tar file)
THANKS (file)

Not sure if of any use but perhaps advice on attachments, everyone to date has gone smoothly.

Thanks

James :$

0

Hang on.. almost there.... lessee, you dl the file testdisk-6.10.win.zip. That extracts to give a folder called testdisk-6.10 containing some files plus dos, ico and win folders. You may delete the dos folder. Okay, you've done all that.
**The doc folder is inside that testdisk-doc-6.10 (tar file)] - drag the doc folder into the testdisk-6.10 folder alongside ico and win folders.
Next, drag the testdisk-6.10 folder into your new parent folder. You've done that.
If you call your parent folder Disk Management you will have to change the paths in my lil .cmd files. Go with Disk Tools.. easier.
Scratch Pad folders are just my own very temp stores. Hang onto the .zip and .bz2 files for the moment, leave them in your dl folder.
I deleted some of those files... my testdisk-6.10 folder contains:
ico, doc, win folders[all contents untouched], plus only changelog and NEWS files.
Check your paths in the cmd files are correct and they should work.
Note... I use Opera on this site [for most browsing, actually]. Firefox has issues with it, IE I don't use.

0

James, to get the ball rolling could you give me these three screenshots, please?
Start Testdisk, choose Create a logfile, shoot the next screen with your disks shown. Save it.
Select the bad drive [Seagate], choose Proceed, then Intel, then Analyse, shoot and save the next screen.
Then choose Quick Search, N for No to Vista.... let it run. Shoot the next screen.
That will do for me for the moment, press q until you are out. Or play if you wish, you will not do any damage unless you agree to Delete or Write etc queries somewhere in there.
Post those three shots, combine them into one if you will.

0

Hi again

I have tried all 3 cmd files, having placed them on the desktop as you suggested.

I have tried to open all 3; both TestDisk Start and PhotoRec (after an initial message Windows can find ......) appear to work, by clicking on the OK button a black box appears as you describe. In any event I have taken 4 screenshots for TestDisk as attached. TestDisk Help won't open, it gives the same 'windows cannot find etc but on clicking ok the message repeats. More importantly the black box has a script saying: The system cannot find the file testdisk.html. I did transfer this file into the Disk Tools folder but it is named documentation (or the tar file is called testdisk-6.10). To help I have now been able to attach a screenshot of the files in Disk Tools\testdisk-6.10\......

Hope this helps and moves things on - I am guessing the help file is because I haven't dropped into the folder correctly.

Thanks again

James

Attachments TestDisk-6.10_files_.JPG 91.25 KB TestDisk_screenshot.JPG 74.64 KB TestDisk_screenshot2.JPG 67 KB TestDisk_screenshot3.JPG 71.88 KB TestDisk_screenshot4.JPG 76.63 KB
0

Hi

Solved the TestDisk_Help issue - it now opens to an html page giving advice on how to use Test Disk - phew.... slow but steady eh!

Thanks again

James

0

James.. just going back to your last screenshot of testdisk-6.10 folder... if you expand that folder in the left margin, click on testdisk-doc-6.10 you will see that a doc folder exists inside it.... drag the doc folder to testdisk-6.10 folder. Then my help .cmd file will apply.
documentation.html is no use to us.
Note that if at any stage in this you get lost or confused you can q your way back and out to start again.
Anyway... your Seagate is detected correctly [shot 1]. In shot 2 it reads the MBR partition table and linked logical partitions' tables and shows a primary partition P, type LANstep [FEhex], not bootable, but the Extended partition and 2 logical partitions are missing. Next, the physical search of the disk sectors reveals [in shot 3] three partitions:
Primary 41381kB 40GB Photo Album
Logical 62915kB 60GB Support Files
Logical 15735kB 15GB Backup
... so we may conclude that the MBR partition table is corrupted.
At the point where you took the shot 3 you must check that your directories and files exist in eg. your Photo Album partition - so start Testdisk, go back to that same screen which is the result of the Quick Search [green text], highlight the top partition and press p. In the new screen you should see your directories and files. If you highlight a directory and press the right arrow you will see files etc inside that.... Do they appear to be all there? [note that at this point you can copy out any file or directory, but I suggest you ignore that for now].
Press q until you are back to the result of Quick Search [the shot 3 window with green text]. Highlight the second partition [Support Files], press p and check its directories and files... Are they there?
***Now....Only if you can answer YES to both those questions, [ and because the structure found in the Quick search shows as correct to me] we can write that to the disk. So...
Press q until you are back to the result of Quick Search [the shot 3 window with green text], then press Enter to continue.
In the next window you will see the same three partitions listed plus one with: E extended LBA 5031 0 1 ....
Yes? then select Write, press Enter, press Y.
Done. The partitions are registered in the MBR partition table.
If you restart Testdisk, select your Seagate [disk 2], choose Proceed, Intel, Analyse you should see your three partitions listed plus the E extended one. Correct? Does the first start with: 1 * HPFS - NTFS 0 1 1 .... ? Good.
If not, shoot that screen, post it.

0

Hi there

Have followed your instructions and attach 4 screenshots, including the last one you requested.

Everything seems to appear as you have suggested, the only small exception appearing to be that following a reboot and re-opening of TestDisk_Start, there is an additional Partition called x extended 12680 1 1 - the screenshot should indicate this - (the screenshot is called TestDisk_Partition check post MBR registration).

So........ the big question for me is..... what happens next??

Thank you again for your help, I am beginning to think we may be reaching the end of the trail, good news for you eh!

Really, many thanks

James

Attachments TestDisk_Partition_check_Backup.JPG 91 KB TestDisk_Partition_check_Photo_Album.JPG 75.13 KB TestDisk_Partition_check_post_MBR_registration.JPG 76.38 KB TestDisk_Partition_check_Support_Files.JPG 90.92 KB
0

Hi

I feel so embarrassed, so relieved and so so grateful.

I have found all my files - words seem inadequate to express my thanks for your help and your patience. I have sat here for minutes just not believeing that everything has returned.

I am unsure as to protocols in this forum but would like somehow to repay you for the help you have given, be it directly or to a Charity of your choice...... I may be slightly out of line here and hope not to have broken any rules but..... the relief is incredible. Not a lifetime of work but many years stored, lost and found!

A zillion thanks and more... please allow me somehow to demonstrate that gratitude.

Yours very thankfully

James

0

Heh... well, thanks, James. I just enjoy discovering things, exploring... I found those pgms and others some time back, they just help me learn more about disk structure and stuff. Glad I could put them to use. Your disk is okay, no actual damage to it [only some data got altered in the "index", and we fixed that] so keep using it. The structures as shown in your third shot [with the E extended and X extended lines] are all correct - it is just the way the partition table is built.
May I sugggest you give some thought to getting the precious stuff onto cds or dvds? CD Rewritables are good. I use an extra harddrive for just backups, too. Syncback free is as good as you need.
Gratitude? Show it to the writer of Testdisk, not me.
And you're welcome. It's been fun.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.