I am missing: WAN Miniport (PTP)
" " PPOE
(Network Monitor)

I came back to my computer and it wouldn't reboot. Tried savemode. All OK except these updates.
Can any one help me?
Thanks in advance.


Recommended Answers

All 4 Replies

The solution involved reinstalling the WAN Miniport (PPTP) driver.
Here's how I did it:

1. Go to device manager and select "Show Hidden Devices" under the View menu.

2. Expand Network adapters. You should see the WAN Miniport (PPTP)

3. Try right clicking on it and uninstalling it. More than likely it
won't allow you to. To get around this update the driver to something "uninstallable" like the MAC Bridge. To do this right click on it and select update driver. Choose no to look on windows update. Then choose to specify a location. Next choose dont search. Next unselect show compatible hardware and find the MAC Bridge under Microsoft. Force it to install it. After thats done you should be able to uninstall your new 'MAC Bridge Miniport."

4. Now that it's gone, lets reinstall it. Go fetch the devcon.exe
package from Microsoft (Search for devcon.exe on google) and extract it somewhere.

5. Go to the command prompt / console (cmd.exe) and get to the folder
with devcon.exe in it.

6. Run this command: devcon.exe install c:\windows\inf\netrasa.inf

7. Go back to the device manager. You should see the WAN Miniport
(PPTP) back.

8. Try making yourself a fresh VPN connection now.

Good Luck

Thank you, francisabey.

Your help was greatly appreciated!

Just a quick word ... if you are with AOL look in System Information & find Rebuild AOL Adapter it will solve the problem with the Miniport trouble.

commented: Zombie feeders. Don't post in an old thread -2

Here is what worked for me:
Re-install ing WAN miniport (IP) device

  • First restore the backup key you deleted from the registry - steps 3-6 were the culprits.
    STEP -A
  • so before you start reinstalling - restore the registry key you might have saved before step 6 by exporting the key before delete. -just double click that backup file to autoinstall

THis will bring back the entry in the device manager - albite with an unknown driver mark on the entry - goto Step B

  • Now the step 9 to 11 are all crap - windows does not allow you to access or change the netrasa.inf file.

  • instead you just need to follow some simple steps
    STEP -B

  • Now just scan for any hardware changes
  • windows automatically updates the WANminiport IP driver using the files
    windows/system32/ndistapi.sys &

  • otherwise you might have to locate this directory for the install to happen

This works!!!! and wallah!!!
Your netcon is back online :)

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.