0

I just got a new pc and everything is working fine except my usb 2.0 flash drives. Every time I save or try to write a file that's bigger than just 100-200 kb, it hangs and then I get a "delayed write failed" error. The drive still appears in windows explorer but shows no files. Reinsterting the drive gets it to appear correctly again.

I have several different flash drives...and several brands, ranging from a 4GB MyFlash to a 16GB Kingston. It does this with all of them regardless of which usb port I use.

Also, I have not had this problem with external hard drives using *the same usb port*. Just the flash drives. They worked fine with my old computer and they work fine on my pc at work, laptops, etc. I have never had this problem until I got this pc.

The pc is built with an Asus mb, 4GB ram, and a quad core AMD Phenom cpu. Not sure what other info I could provide.

It's got to be some sort of setting. I can't save any large files (or reather I can only save really small files) which defeats the purpose of a flash drive!

It has no problem *reading* large files, just writing them. And there is no problem with saving small files.

I have done a search and this seems an old problem with a wide range of causes. I really need to resolve this. HELP!

3
Contributors
12
Replies
13
Views
8 Years
Discussion Span
Last Post by gurukid22
0

Delay write failed means windows could not write to the drive normally this is a harware problem with the drives i would format the drives the run a check disk make sure you check the boxes repair. To do this right click the drive click format the after right click the drive click properties then tools then check now checking both boxes the click ok.

0

Ok, I did exactly that. I reformatted one (it didn't have anything on it at the moment anyway). Then I ran the disk check and it didn't report any errors. (checked off both boxes). But still the problem persists.

It also doesn't make sense that it would be errors with every single flash drive I have, whereas they work perfectly elsewhere.

0

you are right it makes no sense ,are you trying to copy the same data each time ,or is it with any data you try to copy

0

^ Good Point, The delay right failed error may be coming from the internal hard drive with the data you are trying to copy.

it would be a good idea to run Check Disk on all drives.

I have seen this issue when people use laptops and usb hard drives due to lack of power but this does not seem like your problem.

In addition you could try writing to the drive using software it may change something http://www.dmailer.com makes synchronization and backup software for portable devices you could try it

0

It happens no matter which file I use (any one over about 250 kb) and no matter what drive it originates from...an external hard drive or my internal one. I will double check that, though.

0

I tried it various ways...
From an external hard drive
From my internal hard drive
And just saving an existing file on the flash drive.

All came back with the same problem. There are no errors on the hard drives.

I've also got a new symptom...
I couldn't hook up my printer because it uses a parallel port and this new pc doesn't have one (parallel ports are being phased out). So I got a cable which goes from parallel to usb and I installed my printer to a usb port.

Guess what? It prints but only a certain amount, then it cuts off. :S

There's got to be a setting that's making it cut off...either the size is too big or the amount of time it is accessing the port is too long.

0

This is still unresolved for me. I tried a few more things...changing the usb settings in the bios, changing paging options. Nothing has worked. I looked in the events log and found the following:

Event Type: Warning
Event Source: Disk
Event Category: None
Event ID: 51
Date: 6/26/09
Time: 6:56:57 AM
User: N/A
Computer: STEVE-D42CFF3F4
Description:
An error was detected on device \Device\Harddisk1\D during a paging operation.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 03 00 68 00 01 00 b6 00 ..h...¶.
0008: 00 00 00 00 33 00 04 80 ....3..
0010: 2d 01 00 00 00 00 00 00 -.......
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 fe da 05 00 00 00 00 .þÚ.....
0028: 2b 4c 24 00 00 00 00 00 +L$.....
0030: ff ff ff ff 03 00 00 00 ÿÿÿÿ....
0038: 40 00 00 84 02 00 00 00 @..„....
0040: 00 20 0a 12 40 03 20 40 . ..@. @
0048: 00 00 00 00 0a 00 00 00 ........
0050: 00 00 00 00 d0 e3 91 87 ....Ð㑇
0058: 00 00 00 00 60 6a 3f 89 ....`j?‰
0060: 00 00 00 00 7f ed 02 00 ....í..
0068: 28 00 00 02 ed 7f 00 00 (...í..
0070: 08 00 00 00 00 00 00 00 ........
0078: 70 00 02 00 00 00 00 0a p.......
0080: 00 00 00 00 04 02 00 00 ........
0088: 00 00 00 00 00 00 00 00 ........

0

Are you sure the drives work on other computer if so we no its you computer and we no its not the port because the hard drives work. Is a format or windows repair possible it is generally the last resort but i don't know what else to recommend as i have never seen or heard of this.

0

Yes, it works fine on other machines. I even reformatted it on the pc where it is giving problems. I did a repair and it said there were no problems. I don't think it's the drive itself. It seems like some sort of hardware incompatibility.

0

Ok, problem identifed. Can't say it's quite solved yet but at least I know what it is.

Looks like a power issue. It occurred to me that one of the differences between my external hard drives and the flash drives is the hard drives have their own power source. So I got a usb hub and put it in the same port I was testing the flash drive and it worked perfectly. The hub has its own power source. So that means the built in usb ports aren't getting enough power. Solving that is another issue completely. But now thanks to my trusty hub, I have a workaround.

0

Excellent, as mentioned earlier power is a common cause of this type of problem. Another solution to your problem is a double ended usb extension cord you connect one end to your usb device then the other 2 leads to you usb ports and it sucks energy from 2 usb ports instead of one.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.