0

OS: Server 2k8 SP2 64bit Standard Edition
NIC Version/driver: Onboard Realtek PCIe GBE Family Controller 6.223.525.2009

Hello,

This morning I encountered a very strange networking problem with my main PC which has Server 2008 64bit Edition installed. My computer would not connect to the internet. I checked the back of my computer where the NIC lights were, and the green light was solid. I checked the device manager and there were no conflicts there with any networking device.

I thought this would be a simple fix, just a simple reset of my modem and router. However after performing a full reset of these devices I noticed that I still could not connect to the internet. Thinking my problem was now computer-side I checked my settings to ensure they were set to DHCP. They were, I also did a netsh winsock reset and then I restarted my computer. Still no luck, I restarted again and ensured my NIC device was showing up in the BIOS, it was.

Wanting to rule out a modem/router/ISP problem I disconnected the ethernet cord from my router and did a direct connection from my modem to my laptop, and I was able to successfully connect and that's what I am posting on now.

However my problem with my main PC still exists. There are no device driver conflicts in the Device Manager, the Network Settings can still detect whenever an ethernet cord is connected/disconnected, its showing up in the BIOS, the NIC lights are on, its set to DHCP, netsh winsock reset doesn't work, removing updates applied from previous day doesn't work, removing/updating the NIC drivers doesn't work.

I'm thinking that it's a faulty onboard NIC but it seems strange it would do this without giving me any problems before hand. The onboard NIC has worked perfectly for almost a year and a half now. I wake up and find this.

Anyone have any suggestions or should I just suck it up and buy a new NIC?

*EDIT:

After a few more tests, I noticed that the modem and the NIC seem to be communicating, as the orange light on the NIC is blinking at random intervals when connected to the modem, but I am still unable to connect.

*EDIT2:

Spyware (Malwarebytes and Spybot) and AV (AVG) scans come up clean as well.

3
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by Silverion
0

switch off the NIC Card on Bios and start the computer then restart go to bios and switch it on again.

0

Thanks for the replies guys, I did try to ping localhost and received a response, which made this all the more puzzling.

I wound up backing up my data and doing a wipe/reinstall of the OS. The problem is resolved now, thanks.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.